Closed Bug 584348 Opened 9 years ago Closed 9 years ago

Update add-on button triggers no action on click/tap event

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: vladmaniac, Assigned: mfinkle)

Details

Attachments

(1 file)

Steps: 
1. Open Fennec and slide the screen to the left to bring up Options Menu
2. From Options menu select add-on submenu (puzzle icon)
3. Notice the list of installed add-ons and a list of recommended add-ons at the bottom of the content area. 
4. Click on the "Update" button at right top of the menu (in the Your Addons sections) 

================================================================================

Expected: 

There should be a list of updates for all installed add-on. If no updates are available, there should be a proper notification to announce that and give some
feedback at the press/tap/click on the "Update" button. 

================================================================================

Actual:

Tapping on "Update" button triggers no action.
OS: Linux → All
Hardware: ARM → All
Sounds like this is a UI issue: You would like some kind of visible confirmation that Fennec checked for updates, but found none. Is this right?
That's right Mark, thanks
FWIW, I had an old version of Phony 0.2.2, clicked update, and the text appeared saying "A compatibility updated has been applied".   So we need text for when there's no update available.
tracking-fennec: --- → ?
I can confirm this. I had no add-ons installed, only the pre-installed search plugins. Affter pressing the update button, I don't see any indication that anything has happened.
tracking-fennec: ? → 2.0b1+
Assignee: nobody → mark.finkle
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b2pre) Gecko/20100819 Namoroka/4.0b2pre Fennec/2.0a1pre

=================================================================================
Furthermore, Update manager seems to install the same update over and over again, if "update" button is tapped on. Is this expected? I believe it would be nice if previously installed updates would be somehow remembered. 

Echoed Message: "A compatibility update has been applied"
A new bug has been filed for the above comment #5.
Bug 588867
We don't want to popup an alert. If you have add-ons installed (real add-ons, not the search providers) then you should see some text appear in the row while we look for updates.

The search providers are not updatable, so they are ignored.

I can make a patch to simply disable the "Update" button if no updatable add-ons are installed.
Attached patch patchSplinter Review
This patch only enables the "Update" button if an updateable add-on has been installed.

During an update check, we change the strings in the add-on rows, so there is a verification that something is happening.

The patch also makes some updates to the add-on code:
* Adds the new extensions.getAddons.cache.enabled pref
* Adds a restart prompt for compatibility updates since the version bump could mean a restart is needed (we check the pendingOperations)
* I rename "addon" -> "update" and use the real addon object in the update observer now too. It's less confusing since the object being returned was not a real addon object, just some data related to the update.
Attachment #470902 - Flags: review?(mbrubeck)
Comment on attachment 470902 [details] [diff] [review]
patch

>diff --git a/app/mobile.js b/app/mobile.js
>--- a/app/mobile.js
>+++ b/app/mobile.js
>@@ -170,23 +170,23 @@ pref("extensions.ignoreMTimeChanges", fa
>+      if (!anyUpdateable)
>         document.getElementById("addons-update-all").disabled = true;

Do we ever re-enable this button?  Hmm, I guess we never need to, since this would only change after installing a new add-on and restarting Fennec.  Okay, nevermind.

>@@ -594,37 +599,41 @@ var ExtensionsView = {
>+    let addon = element.addon;

Is this used anywhere?

r=mbrubeck with that last question answered.
Attachment #470902 - Flags: review?(mbrubeck) → review+
(In reply to comment #9)

> >@@ -594,37 +599,41 @@ var ExtensionsView = {
> >+    let addon = element.addon;
> 
> Is this used anywhere?

Yep:
>           case "compatibility":
>             statusMsg = strings.getString("addonUpdate.compatibility");
>+            if (addon.pendingOperations & AddonManager.PENDING_INSTALL || addon.pendingOperations & AddonManager.PENDING_UPGRADE)
>+              updateable = true;
pushed:
http://hg.mozilla.org/mobile-browser/rev/4501ce985781
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified on Build:
Mozilla /5.0 (Android;Linux armv7l; rv:2.0b6pre)
Gecko/20100903 Firefox/4.0b6pre Fennec /2.0b1pre

and

Mozilla /5.0 (Maemo;Linux armv7l; rv:2.0b6pre)
Gecko/20100903 Firefox/4.0b6pre Fennec /2.0b1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.