Last Comment Bug 584357 - TextRunWordCache::MakeTextRun doesn't null check new [] result
: TextRunWordCache::MakeTextRun doesn't null check new [] result
Status: RESOLVED FIXED
[sg:critical?]
:
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: :Ehsan Akhgari
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 07:21 PDT by Olli Pettay [:smaug] (TPAC)
Modified: 2010-09-27 18:32 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.9-fixed
.12-fixed


Attachments
Patch (v1) (2.60 KB, patch)
2010-08-04 08:50 PDT, :Ehsan Akhgari
no flags Details | Diff | Splinter Review
Patch (v1) (2.60 KB, patch)
2010-08-04 15:15 PDT, :Ehsan Akhgari
roc: review+
dveditz: approval1.9.2.9+
dveditz: approval1.9.1.12+
Details | Diff | Splinter Review

Description Olli Pettay [:smaug] (TPAC) 2010-08-04 07:21:30 PDT
This *might* be the reason for bug 583077, at least on branches.
Comment 1 :Ehsan Akhgari 2010-08-04 08:50:56 PDT
Created attachment 462788 [details] [diff] [review]
Patch (v1)

But shouldn't operator new[] been infallible?
Comment 2 Olli Pettay [:smaug] (TPAC) 2010-08-04 08:56:47 PDT
On trunk yes, but not on branches.
Comment 3 :Ehsan Akhgari 2010-08-04 08:58:56 PDT
Ah, yes.  I missed the branch mention for some reason.  Then I guess we only need to take this patch on branches.
Comment 4 :Ehsan Akhgari 2010-08-04 15:15:53 PDT
Created attachment 462949 [details] [diff] [review]
Patch (v1)

The typos that I make sometimes amaze me...
Comment 5 :Ehsan Akhgari 2010-08-04 15:23:25 PDT
Comment on attachment 462949 [details] [diff] [review]
Patch (v1)

This bug only affects branches, so I'm asking approval only for branches.
Comment 6 Daniel Veditz [:dveditz] 2010-08-06 11:07:59 PDT
Comment on attachment 462949 [details] [diff] [review]
Patch (v1)

Approved for 1.9.2.9 and 1.9.1.12, a=dveditz for release-drivers

Note You need to log in before you can comment on or make changes to this bug.