Closed Bug 584361 Opened 11 years ago Closed 11 years ago

Empty and not editable text edit window when replying or forwarding certain messages (HTML mail has element of conenteditable="yes")

Categories

(MailNews Core :: Composition, defect)

x86
All
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 525359

People

(Reporter: hka, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Opera/9.80 (X11; Linux i686; U; en) Presto/2.5.24 Version/10.53
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100720 Lanikai/3.1.1

When I try to forward certain messages the window that opens is empty and I can't edit it. Sometimes, using reply works but not always.

Forward problem happens every time with the message attached. Same happens on Windows XP with TB 3.1.1

Reproducible: Always

Steps to Reproduce:
1. Open attached message using File->open
2. Click Forward

Actual Results:  
Text edit box is empty, can't input new text

Expected Results:  
Text edit box should display message being forwarded

Happens on working profiles of two different users on two different computers and operating systems.

Cleaning TB profile (removing ~/.thunderbird) or running in safe-mode doesn't help.
Attachment #462770 - Attachment mime type: application/octet-stream → text/plain
Forgot to mention one more thing: after trying to forward this message I can't reply to or forward any other messages.
Attachment #462770 - Attachment mime type: text/plain → message/rfc822
Confirming with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b3pre) Gecko/20100804 Shredder/3.2a1pre
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Composition
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: front-end → composition
(In reply to comment #1)
> sanitized e-mail that causes the issue

Newline characters is LF(0x0a) instead of CRLF(0x0d0a) even though .eml file. Saved in .eml by Thunderbird? Or crafted mail data using text editor on Linux?

(In reply to comment #0)
> Steps to Reproduce:
> 1. Open attached message using File->open
> 2. Click Forward

Two concerns.
(A) LF instead of CRLF.
(A-1) Can you reproduce problem with .eml file with correct CRLF?
(A-2) Can you reproduce problem with imported mail?
      Drag&Drop the .eml file(with LF) to thread pane of a local mail folder.
      (.eml is imported as mail)
      View the imported mail, Forward
(B) Forward at mail window for a .eml file.
    Dup of bug listed in Dependency tree for meta Bug 269826?

(In reply to comment #2)
> Forgot to mention one more thing: after trying to forward this message I can't
> reply to or forward any other messages.

At where/with what operation you can't reply to or forward any other message?
What phenomenon do you call "I can't reply to or forward any other messages"?
Reply or Forward button/menue for any mail in mail folder doesn't work any more?
Is there any error message in Error Console or Activity Manager?
What is recovery procedure from it? Restart of Tb is mandatory?
(In reply to comment #4)
> (In reply to comment #1)
> > sanitized e-mail that causes the issue
> 
> Newline characters is LF(0x0a) instead of CRLF(0x0d0a) even though .eml file.
> Saved in .eml by Thunderbird? Or crafted mail data using text editor on Linux?

No, it's an edited file as saved by Thunderbird - the newline characters were saved the UNIX way by Thunderbird.

Besides, I highly doubt that this could be the culprit. The first time I saw the issue was trying to forward regular e-mail form the inbox, not by forwarding e-mail saved to disk or any other wizardy.

> 
> (In reply to comment #0)
> > Steps to Reproduce:
> > 1. Open attached message using File->open
> > 2. Click Forward
> 
> Two concerns.
> (A) LF instead of CRLF.
> (A-1) Can you reproduce problem with .eml file with correct CRLF?

Changing LF to CRLF doesn't fix the issue.

> (A-2) Can you reproduce problem with imported mail?
>       Drag&Drop the .eml file(with LF) to thread pane of a local mail folder.
>       (.eml is imported as mail)
>       View the imported mail, Forward

Drag and drop doesn't work, I use KDE. My co-worker can't forward or reply to this e-mail from her inbox.

> (B) Forward at mail window for a .eml file.
>     Dup of bug listed in Dependency tree for meta Bug 269826?

Couldn't find anything similar. 

What is important to reproduce this bug is to use default settings for Thunderbird: format and view messages as HTML, not text.

When using text view and disabling HTML, the e-mail is forwarded the way it should.
 
> (In reply to comment #2)
> > Forgot to mention one more thing: after trying to forward this message I can't
> > reply to or forward any other messages.
> 
> At where/with what operation you can't reply to or forward any other message?
> What phenomenon do you call "I can't reply to or forward any other messages"?
> Reply or Forward button/menue for any mail in mail folder doesn't work any
> more?

What I mean, is that all the other messages start behaving in the same way as the one in question. After trying to forward or reply to this mail (either on my PC or on my co-workers PC) all e-mails will show empty, non editable body in message compose window when trying to "reply to" or "forward" them.

> Is there any error message in Error Console or Activity Manager?
> What is recovery procedure from it? Restart of Tb is mandatory?

Only warnings in error console, activity manager is empty, to recover I have to restart Thunderbird.

Warnings (original file):

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: mailbox:///home/hka/Re:%20licencja%20-%20certyfikat%20na%20program.eml?type=application/x-message-display&number=0
Line: 41

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: mailbox:///home/hka/Re:%20licencja%20-%20certyfikat%20na%20program.eml?type=application/x-message-display&number=0
Line: 45

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: mailbox:///home/hka/Re:%20licencja%20-%20certyfikat%20na%20program.eml?type=application/x-message-display&number=0
Line: 158

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: mailbox:///home/hka/Re:%20licencja%20-%20certyfikat%20na%20program.eml?type=application/x-message-display&number=0
Line: 162

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: about:blank
Line: 1

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: about:blank
Line: 1

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: about:blank
Line: 1

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: about:blank
Line: 1

Edited file:

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: mailbox:///home/hka/broken.eml?type=application/x-message-display&number=0
Line: 19

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: mailbox:///home/hka/broken.eml?type=application/x-message-display&number=0
Line: 23

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: mailbox:///home/hka/broken.eml?type=application/x-message-display&number=0
Line: 103

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: mailbox:///home/hka/broken.eml?type=application/x-message-display&number=0
Line: 107

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: about:blank
Line: 1

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: about:blank
Line: 1

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: about:blank
Line: 1

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: about:blank
Line: 1
(In reply to comment #5)
> What is important to reproduce this bug is to use default settings for
> Thunderbird: format and view messages as HTML, not text.

What is your View/"Message Body As" choice? Oriinal HTML? Simple HTML?
Dup of bug 394322, or .eml file version of bug 394322?

By the way, never paste long data, please. Save in text file and attach the text file to bug, please.
(In reply to comment #6)
> (In reply to comment #5)
> > What is important to reproduce this bug is to use default settings for
> > Thunderbird: format and view messages as HTML, not text.
> 
> What is your View/"Message Body As" choice? Oriinal HTML? Simple HTML?

Happens both on Original HTML and Simple HTML.

> Dup of bug 394322, or .eml file version of bug 394322?

No, I don't see anything in the body, not even my signature.
New findings about Edit As New/Forward/Reply in HTML mode of attached mail.
Edit As New(Tb 3.1.2, Tb trunk), Forward(Tb 3.1.2, Tb trunk), Reply(Tb 3.1.2) :
  Nothing is displayed at compose window, including signature as you say,
  but mail data is saved in Drafts folder by "Save As Draft".
  View of draft is normal, but Edit Draft show nothing.
Reply(Tb trunk) :
  Nothing is displayed at compose window. <html> ... <html> only is saved
  by "Save As Draft". So, nothing is shown by View nor Edit.

As "Edit As New" case is simplest(logic for Reply/Forward is irrelevant), check with "Edit As New" seems better.
Non terminating tag occurs in Edit mode? CSS in the original HTML is cause? If CSS is relevant, error messages you saw in Error Console may be relevant.
contenteditable="true" is probably culprit. Changing HTML to next(two places) resolved problem.
> <!--
>                     <table
>  style="margin: 3px; width: 100%; font-family: Times New Roman; font-size: 12pt;"
>  contenteditable="true" width="100%">
> -->
>                     <table
>  style="margin: 3px; width: 100%; font-family: Times New Roman; font-size: 12pt;"
>  width="100%">

Example of contenteditable bugs.
> Bug 561307 Can not type inside contentEditable elements and form elements
>            positioned over a Flash object after the second click on them.
> Bug 549046 contenteditable works in XHTML, not in HTML5
Version: unspecified → Trunk
Recovery procedure.
(1) Problem occurs at a compose window => close the compose window
(2) Open first compose window => problem occurs as compose window is re-used
(3) Open second compose window => problem doesn't occur
(4) Close second compose window => this becomes latest window
(5) Close first compose window on which problem remains
(6) Write => problem doesn't occur, because window of (3)/(4) is re-used
Summary: Empty and not editable text edit window when replying or forwarding certain messages → Empty and not editable text edit window when replying or forwarding certain messages (HTML mail has element of conenteditable="yes")
(In reply to comment #8)
> New findings about Edit As New/Forward/Reply in HTML mode of attached mail.
> Edit As New(Tb 3.1.2, Tb trunk), Forward(Tb 3.1.2, Tb trunk), Reply(Tb 3.1.2) :
>   Nothing is displayed at compose window, including signature as you say,
>   but mail data is saved in Drafts folder by "Save As Draft".
>   View of draft is normal, but Edit Draft show nothing.

Can't check this, hit another bug: when saving as draft, Thunderbird shows warning message:

"Unable to save your message as draft.
Please verify that your Mail & Newsgroups account settings are correct and try again"

When I try to save the forwarded message. Error console and Activity Manager is clean.
When saving it as file Tb suggest saving it as HTML, not eml!

I can save other messages as draft/template though, only the ones that I try to edit from attachments are affected.

> Reply(Tb trunk) :
>   Nothing is displayed at compose window. <html> ... <html> only is saved
>   by "Save As Draft". So, nothing is shown by View nor Edit.
> 
> As "Edit As New" case is simplest(logic for Reply/Forward is irrelevant), check
> with "Edit As New" seems better.
> Non terminating tag occurs in Edit mode? CSS in the original HTML is cause? If
> CSS is relevant, error messages you saw in Error Console may be relevant.

"Edit As New" shows empty window too for the original message, fixed message 
(as suggested below) works without problems.

(In reply to comment #9)
> contenteditable="true" is probably culprit. Changing HTML to next(two places)
> resolved problem.
> > <!--
> >                     <table
> >  style="margin: 3px; width: 100%; font-family: Times New Roman; font-size: 12pt;"
> >  contenteditable="true" width="100%">
> > -->
> >                     <table
> >  style="margin: 3px; width: 100%; font-family: Times New Roman; font-size: 12pt;"
> >  width="100%">
> 
> Example of contenteditable bugs.
> > Bug 561307 Can not type inside contentEditable elements and form elements
> >            positioned over a Flash object after the second click on them.
> > Bug 549046 contenteditable works in XHTML, not in HTML5

Yes, that's the one, after removing contenteditable from source of original message I can reply and forward it.
Still can't save it though, but it looks as completely different bug and unrelated to message in question.

(In reply to comment #10)
> Recovery procedure.
> (1) Problem occurs at a compose window => close the compose window
> (2) Open first compose window => problem occurs as compose window is re-used
> (3) Open second compose window => problem doesn't occur
> (4) Close second compose window => this becomes latest window
> (5) Close first compose window on which problem remains
> (6) Write => problem doesn't occur, because window of (3)/(4) is re-used

Yes, this seems to be working too.

Any ideas for a work-around except using Plain text e-mail?
Bug 525359 seems first report of the problem.
(In reply to comment #12)
> Bug 525359 seems first report of the problem.

Yep seems to be dupes. Let's dup them Thanks for looking things up Wada-san.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 525359
You need to log in before you can comment on or make changes to this bug.