If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Provide a mechanism to extract stylesheet changes from inspector

RESOLVED DUPLICATE of bug 583041

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 583041
7 years ago
7 years ago

People

(Reporter: rc, Assigned: pcwalton)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kd4b5])

(Reporter)

Description

7 years ago
CSS modifications should be captured and easily extractable from the inspector for application to the developer's server/locally-stored stylesheets.

Updated

7 years ago
Whiteboard: [kd4b4]
When you say "captured", do you mean just the changes which consist of the user poking at things through the inspector (sensible, given the use case you mention), or does it include any/all dynamic style modifications (e.g., from page script as well)?
(Reporter)

Comment 2

7 years ago
These will be changes made manually to the stylesheets through the CSS editor we'll be implementing in bug 583041. I'm focusing specifically on stylesheets for the moment because it should be fairly easy to generate a diff-like log of those changes.

HTML changes will follow suit.

If you're looking specifically for changes that come through JS DOM manipulation, we're hoping the Console will provide some output showing those when the DOM listener stuff makes it in.

Comment 3

7 years ago
It's worth noting that bug 585563 suggests providing an alternate way of editing properties via the style panel.
Assignee: nobody → pwalton

Updated

7 years ago
Whiteboard: [kd4b4] → [kd4b5]

Comment 4

7 years ago
The CSS editor provided in bug 583041 provides export functionality.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583041
You need to log in before you can comment on or make changes to this bug.