Make saveSearch() in search panel work post-places

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: kairo, Unassigned)

Tracking

({regression})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Bug 580660 removes the bookmarking function from search-panel.js and replaces it with a temporary comment. We should fix this.
Maybe we need to look into the whole panel with OpenSearch stuff anyhow, so I didn't bother too much when creating the places patch.
Keywords: regression
Version: unspecified → Trunk
Nothing actually calls this version of saveSearch(). I checked all the way back to Mozilla Suite 1.7.13: 2006071107.

There were other UI[1] with their own versions of saveSearch() but those were removed somewhere between 1.7.13 and 1.8b1

[1]
search/find.xul(.js)
search/internet.xul(.js)

Anyone remember what those do?

WONTFIX?
Yes, WONTFIX due to the simple reason that saveSearch() should not even exist any more after the switch to OpenSearch. As comment #0 tells, this has been filed post-places-bookmarks but pre-opensearch. ;-)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.