Failure in test_crashreporter_crash.js , test_crash_purevirtual.js, test_crashreporter_crash_profile_lock.js | test failed (with xpcshell return code: 0), with "crasher_subprocess_head.js:14: TypeError: Components.interfaces.nsITestCrasher is undefined"

VERIFIED DUPLICATE of bug 584720

Status

()

Toolkit
Crash Reporting
VERIFIED DUPLICATE of bug 584720
8 years ago
8 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281010957.1281012154.21613.gz
WINNT 5.2 mozilla-central opt test xpcshell on 2010/08/05 05:22:37
s: win32-slave51
test_crash_purevirtual.js | test failed (with xpcshell return code: 0)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281017371.1281019685.20274.gz
WINNT 5.2 mozilla-central opt test xpcshell on 2010/08/05 07:09:31
s: win32-slave19
test_crashreporter_crash.js | test failed (with xpcshell return code: 0)

In both cases, the failure has something like this:
> e:\builds\moz2_slave\mozilla-central-win32-opt-unittest-xpcshell\build\xpcshell\tests\crashreporter_test\unit\crasher_subprocess_head.js:14: TypeError: Components.interfaces.nsITestCrasher is undefined
> -e:1: TypeError: Components.interfaces.nsITestCrasher is undefined
> e:\builds\moz2_slave\mozilla-central-win32-opt-unittest-xpcshell\build\xpcshell\tests\crashreporter_test\unit\crasher_subprocess_tail.js:2: TypeError: Components.classes['@mozilla.org/testcrasher;1'] is undefined

I originally reported this as bug 583591 comment 16, but ted says this Windows issue is different from what was going on in that bug.
(Reporter)

Comment 1

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281030991.1281034013.19563.gz
WINNT 5.2 mozilla-central opt test xpcshell on 2010/08/05 10:56:31
s: win32-slave40
TEST-UNEXPECTED-FAIL | e:\builds\moz2_slave\mozilla-central-win32-opt-unittest-xpcshell\build\xpcshell\tests\crashreporter_test\unit\test_crashreporter_crash_profile_lock.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | e:/builds/moz2_slave/mozilla-central-win32-opt-unittest-xpcshell/build/xpcshell/tests/crashreporter_test/unit/head_crashreporter.js | No minidump found! - See following stack:
Summary: Failure in test_crashreporter_crash.js , test_crash_purevirtual.js | test failed (with xpcshell return code: 0), with "TypeError: Components.interfaces.nsITestCrasher" → Failure in test_crashreporter_crash.js , test_crash_purevirtual.js, test_crashreporter_crash_profile_lock.js | test failed (with xpcshell return code: 0), with "crasher_subprocess_head.js:14: TypeError: Components.interfaces.nsITestCrasher is undefined"
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584720
V.Duplicate
No longer blocks: 438871
Status: RESOLVED → VERIFIED
Whiteboard: [orange]
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.