Closed Bug 585158 Opened 11 years ago Closed 11 years ago

Error: error setting current persona

Categories

(Mozilla Labs Graveyard :: Personas Plus, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cbook, Assigned: jose)

Details

Steps to reproduce:

RC2 of Personas 1.6
Click on Custom Personas. Do no changes and click ok
-->

Error: error setting current persona: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: file:///C:/Users/mozilla/AppData/Roaming/Mozilla/Firefox/Profiles/9g82gx55.default/extensions/personas@christopher.beard/modules/service.js :: anonymous :: line 1087"  data: no]
Source File: file:///C:/Users/mozilla/AppData/Roaming/Mozilla/Firefox/Profiles/9g82gx55.default/extensions/personas@christopher.beard/modules/service.js
Line: 609
Assignee: cbeard → jose
Target Milestone: -- → 1.6
Fixed in rev:
http://hg.mozilla.org/labs/personas/rev/8007a3ca4cc2

The problem was that the Personas service was trying to cache the header and footer images even when they were expressed as base64 strings, e.g.:

"data:image/png;base64,iVBORw..."

This occurs in the Custom Persona Editor when the user does not specify a header or footer image file. A transparent 1x1 px base64 string image is used as a workaround for bug 532741.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.