Closed Bug 585178 Opened 11 years ago Closed 3 years ago

fennec crashes while running mochitest content/media/test/test_bug495145.html

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: crash)

While working on the mochitests on my n900 with a 2.0 gtk build, I find a crash (as a note, I set browser.tabs.remote=false).

Nokia-N900-42-11:/home/user/gtk/mochitest# cat ../fennec/application.ini 
[App]
Vendor=Mozilla
Name=Fennec
Version=2.0a1pre
BuildID=20100802011501
SourceRepository=http://hg.mozilla.org/mobile-browser
SourceStamp=143255567eca
Copyright=Copyright (c) 2008 Mozilla.org
ID={a23983c0-fd0e-11dc-95ff-0800200c9a66}

Nokia-N900-42-11:/home/user/gtk/mochitest# python runtests.py --certificate-path=../certs --xre-path=../fennec --utility-path=../bin --appname=../fennec/fennec --test-path=content/media/test/test_bug495145.html
INFO | runtests.py | Server pid: 1497
INFO | runtests.py | Websocket server pid: 1502
INFO | runtests.py | Running tests: start.

pk12util: PKCS12 IMPORT SUCCESSFUL
INFO | automation.py | SSL tunnel pid: 1510
INFO | automation.py | Application pid: 1513
Server listening on port 4443 with cert pgo server certificate
WARNING: gtk_widget_set_sensitive: assertion `GTK_IS_WIDGET (widget)' failed: 'glib warning', file /home/cltbld/build/mobile-trunk-maemo5-gtk-nightly/mozilla-central/toolkit/xre/nsSigHandlers.cpp, line 193
WARNING: gtkwidget.c:9321: widget class `GtkMenuBar' has no property named `window-dragging': 'glib warning', file /home/cltbld/build/mobile-trunk-maemo5-gtk-nightly/mozilla-central/toolkit/xre/nsSigHandlers.cpp, line 193
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
Assertion 'pthread_mutex_destroy(&m->mutex) == 0' failed at pulsecore/mutex-posix.c:83, function pa_mutex_free(). Aborting.
TEST-UNEXPECTED-FAIL | automation.py | Exited with code -11 during test run
INFO | automation.py | Application ran for: 0:00:46.494934
INFO | automation.py | Reading PID log: /var/tmp/tmpJO5wQZpidlog
==> process 1513 launched child process 1542
INFO | automation.py | Checking for orphan process with PID: 1542
PROCESS-CRASH | automation.py | application crashed (minidump found)
No symbols path given, can't process dump.
Neither MINIDUMP_STACKWALK nor MINIDUMP_STACKWALK_CGI is set, can't process dump.
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.
Nokia-N900-42-11:/home/user/gtk/mochitest#
Updated bug summary to the right test filename
Summary: fennec crashes while running mochitest content/media/test/test_bug491145.html → fennec crashes while running mochitest content/media/test/test_bug495145.html
Loading this test into Fennec directly does not cause a crash.
(In reply to comment #2)
> Loading this test into Fennec directly does not cause a crash.

on Linux desktop. Do we even turn on the video features for Maemo?
hmm, on 'BuildID=20100809012424', I am unable to reproduce.  It looks like we might be in the clear on this.  Since there is talk of running tests on a linux version of fennec (could be desktop or some arm variant) we should determine if these tests should be run on all mobile platforms or not.
while rerunning the directory of tests (as automation would) this worked the first time, but failed a second time.  I suspect this is related to low memory conditions.
Severity: normal → critical
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.