Migrate homepage pref when the home button goes away

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
7 days ago

People

(Reporter: tiago.morbus.sa, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)

Since the Home Button is going to be replaced by the Home Tab in Firefox 4, and since the Home Tab is not going to be easy to disable or override, and since it's going to a place (the about:home thing) that's going to contain interface that's not available elsewhere, I believe we should include a way for the user to open their home pages (if they closed them already, or if they just want to open them again).

Creating a widget in about:home seems to me the best way to do it. This is major, because otherwise there's no way to open home pages.

P.S.: Maybe we should change the name from "home pages" to "startup pages". To avoid confusion.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 551849
An idea that's been tossed around is to turn your home page(s) into app tab(s) and that way they are there at startup with your home tab. I'll update this bug as decisions are made
(Reporter)

Comment 2

8 years ago
Then there's no planned way to open them once their closed?

That's not exactly... well... good?

And then there's that where some (if not most?) users don't use their home pages as app tabs but rather as starting pages.

I discussed this here:

http://groups.google.com/group/mozilla.dev.usability/browse_thread/thread/f1833c54aa6d64f9

I believe all I have to say is clearly explained there. I think it's not sensible to leave any of those issues I brought forth unaddressed. One way or another.

Thanks for taking care of this Paul :)

Updated

8 years ago
Version: unspecified → 3.6 Branch

Updated

8 years ago
Version: 3.6 Branch → Trunk

Updated

7 years ago
Component: Theme → General
QA Contact: theme → general

Comment 3

7 years ago
This is a design issue that needs to be solved before we ship a home tab. If we go forward with the idea of turning home pages into app tabs, we need to decide if this is a one-time migration thing, or if this is something that users can customize for future startsups.

Regardless of this decision, I think we need to change the Startup preferences UI, so we'll need some designs for that.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Summary: Create a way to open home page(s) for Firefox 4 → Figure out what to do with home page(s) when the home tab replaces the home button

Comment 5

7 years ago
HomeButton is not only used at startup , it is also used during browsing when u want to open couple of sites or one site which u had set as home. After having home tab , u will just be able to set up startup pages , there is no functionality to act as a button to which u click and get ur homepages

Comment 6

7 years ago
(In reply to bogas04 from comment #5)
> HomeButton is not only used at startup , it is also used during browsing
> when u want to open couple of sites or one site which u had set as home.
> After having home tab , u will just be able to set up startup pages , there
> is no functionality to act as a button to which u click and get ur homepages

The plan is for your home page to become a (removable) app tab, so instead of the clicking on the home button to get to that page, you can just click on that tab.

Comment 7

7 years ago
What if i have set multiple home pages? How would a single tab accommodate that?

Comment 8

7 years ago
(In reply to bogas04 from comment #7)
> What if i have set multiple home pages? How would a single tab accommodate
> that?

There would be multiple app tabs.

Comment 9

7 years ago
If so then a home button serves the job better...

Comment 10

7 years ago
(In reply to bogas04 from comment #9)
> If so then a home button serves the job better...

I'm not sure how that is better. Even if you're pressing the button, only the first home page will be focused, so you'd have to click on another tab if you wanted any of the other pages.

There are still a lot of technical challenges in the way of implementing this design, so we will need to iterate as we develop it. Your feedback is welcome, but please give us a chance to implement the design so that you can try it out before deciding the old way was better. We know that change can be hard, but we also don't want that to stop us from trying to make Firefox better :)

Comment 11

7 years ago
Apologizes if i hinder your development process. 
Sometimes we like to see our homepages , but not always , home button shows them whenever you click it. However with home tab , or mere app tabs , you would like to "pin" those tabs which give you notifications , which might tell you "hey stop your work and see this". These pages may not be home pages. 

A suggestion : For people with multiple pages , why not let hometab stay there the way it is designed to be , but upon clicking it will open all home pages just like a home button. But i don't know how would a fancy home tab page (like in mockups) would come in play with such condition ...

Comment 12

7 years ago
http://trunc.it/hvtn7 This style pretty much reflects what i just suggested.

Comment 13

7 years ago
A easy solution could be to have the home page distinct from the starting page even though currently they are one and the same.

When a new firefox session is started, the tab order on the top should be:
"home app tab" ; "starting page"
...with the focus on the starting page

The default starting page could be the nice clean search page that already greets firefox users.  If they have a custom home page, it would become their custom starting page and meeting their expectations.

This means that once the home app tab is deployed it wont force itself on users, allowing the browser to startup on the same page it always has.  Users can then discover the home app tab during browser use as if it was always there.  An inexperienced user could even discover it after closing all other tabs.
>This means that once the home app tab is deployed it wont force itself on users, >allowing the browser to startup on the same page it always has.

yeah that's our thinking as well.

the Home tab by default will be very similar to the current about:home, (basically just a search field).  If the user wants to customize it with additional functionality, that's entirely up to them.  But we want to mostly start out as a clear canvas for them to customize to their liking (or keep clear).

Comment 15

7 years ago
Sounds good!

I was just wondering if a user currently has a custom home page, would this then disappear when about:home is turned into a customizable app tab? It seems that if there also was something like about:start or about:begin, users with custom home pages could still be greeted by that page and not have it interfere with the new home app tab.
(In reply to bogas04 from comment #11)
> Apologizes if i hinder your development process. 
> Sometimes we like to see our homepages , but not always , home button shows
> them whenever you click it. However with home tab , or mere app tabs , you
> would like to "pin" those tabs which give you notifications , which might
> tell you "hey stop your work and see this". These pages may not be home
> pages. 
> 
> A suggestion : For people with multiple pages , why not let hometab stay
> there the way it is designed to be , but upon clicking it will open all home
> pages just like a home button. But i don't know how would a fancy home tab
> page (like in mockups) would come in play with such condition ...

One of the ways to make the Home tab act as a Home button is to introduce this feature through right click menu. It should have "open custom Home pages (or start-up pages to avoid confusion)". More options like replace current tabs, open in app tabs, open in normal tabs and open in new group can be added. 

Alternatively the Home Tab could be set to open custom Home page/start-up pages when the user double click the tab button. This idea is better than the first idea because users can perform a single action to open custom home pages just like the current approach(by pressing on the home page button). Then from here more option like replace current tabs, open in app tabs, open in normal tabs and open in new group can be added(like the first idea). 

Obviously not everyone will be happy about the change, one way to make less people unhappy is to implement ideas that is similar to the second idea. By implementing similar approaches to the current approach, users will take less time to learn how to use the feature and more time using the web. This will make them like Firefox.
We can have a widget on the about:home page that shows thumbnails for all "Start-up pages" selected by the user. Whenever the user wants to reopen one or more of them he can come to the home tab and launch it. These pages would be like bookmarks with their page thumbnails displayed in addition.

Further there can be an option to add a page to start-up from the tab context menu. Also there can be an option for switch-to-tab if the page is already open.

The drawback of this and some other models discussed above is that this is not the conventional way of handling "Home page", many users may be uncomfortable with that. Instead we can have a Home tab that shows frequently visited sites (like the upcoming new tab page) and a search box.

Comment 18

7 years ago
There are definitely lots of different ways we could go here, but I think we need to converge on the simplest possible solution. To avoid maintaining the homepage pref, I think we should add migration code that checks to see if there is a user set value from browser.startup.homepage, and the do something if there is.

I'm cc'ing Boriss (the UX point person for the home tab) to get some authoritative input on what that something is. Alex's idea was to turn these homepages into app tabs, but there are also ideas about making them into bookmarks to ensure there is no data loss.

I think making a customizable set of pages on the home tab is out of scope for this bug, as is making startup prefs more complicated. We can do these in the future, but the point of this bug is just to make sure users don't lose pages they're storing in the homepage pref (and keep in mind, the vast majority of users have only one homepage, and most of those haven't even customized it away from the default).
Assignee: nobody → margaret.leibovic
Keywords: uiwanted
Summary: Figure out what to do with home page(s) when the home tab replaces the home button → Migrate homepage pref when the home button goes away

Comment 19

7 years ago
Created attachment 569832 [details] [diff] [review]
wip

Based on the patch from bug 544819, I started working on a patch that gets rid of the current home page pref UI, and it does a one-time migration to make app tabs out of the home pages. Some issues with this approach:
-Making the app tabs doesn't work well with session restore, but bug 544819 also needs to deal with some session restore problems, so maybe this will be fixed by the.
-If you are restoring a session, which windows should get these new app tabs? One of them? All of them (this would be more complicated to implement)?
-This doesn't check to see if these home pages are already in app tabs, and this is really hard to do if you want to avoid avoid duplicating sites, not just unique pages.

Right now this patch leaves the browser.startup.homepage pref alone, but this pref is used in a bunch of places (e.g. "get me out of here" on malware sites). I feel like it would be scope creep to try to change all the places we use this, but it feels wrong to remove the UI to edit this pref if we're using it for (even relatively obscure) things. I'm tempted to reset the value of this pref, but that also feels wrong. I guess we could just look into the uses of the pref in follow-up bugs and clean things up as we find them.

Comment 20

7 years ago
I love all the new features and designs for firefox but this "home tab" thing sucks hard.

Updated

7 years ago
Assignee: margaret.leibovic → nobody
Keywords: uiwanted
No longer blocks: 551849
Status: NEW → RESOLVED
Last Resolved: 7 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.