Firefox Sync fails to sync "Use a master password" checkbox

RESOLVED DUPLICATE of bug 540975

Status

Cloud Services
General
RESOLVED DUPLICATE of bug 540975
8 years ago
8 years ago

People

(Reporter: richard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Firefox Sync 1.4.3

On a new Firefox Sync installation choosing "Replace all data on this computer with your Firefox Sync data" fails to sync the checked status of the "Use a master password" checkbox as well as the master password itself.

Reproducible: Always

Steps to Reproduce:
1. On computer A, install sync, check the "Use a master password" checkbox and set a master password.   

2. Sync computer A.

3. On computer B install Firefox, and Firefox Sync.

4. Configure Firefox sync with the same sync account as computer A and set the dropdown box to "Sync Everything".

5. Select "Replace all data on this computer with your Firefox Sync data".

6. Sync computer B. 
Actual Results:  
The "Use a master password" checkbox on computer B remains unchecked.

Expected Results:  
The "Use a master password" checkbox on computer B should be checked, and the master password from computer A should be the master password for computer B.
(Reporter)

Comment 1

8 years ago
Bug 540975 looks like a better approach.   Users have an expectation that checking the "Sync Passwords" box will sync all their passwords, so a warning on synced machines without a Master Password set seems in order.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 540975

Updated

8 years ago
Component: Needs Triage → General
QA Contact: needstriage → general
You need to log in before you can comment on or make changes to this bug.