Closed Bug 585371 Opened 10 years ago Closed 10 years ago

Regression: "View Image" -> (automatic) resizing of (large) pictures not working anymore

Categories

(Core :: ImageLib, defect)

x86
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla2.0b7
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: c.ascheberg, Assigned: bholley)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b4pre) Gecko/20100807 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b4pre) Gecko/20100807 Minefield/4.0b4pre

See steps below. The given URL is just one possible testcase, if your browser window is small enough. I need to reload the image to get the functionality working again (CTRL+R).

Reproducible: Always

Steps to Reproduce:
1. visit a website showing a large picture
2. right click on image, "View Image" (image needs to be bigger than browser window)
Actual Results:  
The image is shown at original size, image is not resized to width of browser window. Clicking on the image has no effect, no icon shown.

Expected Results:  
The image is resized to width of browser window automatically. Hovering over the image shows the Zoom-in-Icon, clicking the image zooms image to its original size.
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/5f857be14db9
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100727 Minefield/4.0b3pre ID:20100728145944
Fails:
http://hg.mozilla.org/mozilla-central/rev/b8b62b351c09
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100728 Minefield/4.0b3pre ID:20100728152620
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5f857be14db9&tochange=b8b62b351c09
Candidate bug:
Bug 572520 - make all imgIDecoderObserver notifications asynchronous
Blocks: 572520
Status: UNCONFIRMED → NEW
Component: General → ImageLib
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → imagelib
Target Milestone: --- → mozilla2.0
Version: unspecified → Trunk
I wonder if this is the same issue as bug 583825...
blocking2.0: --- → ?
blocking2.0: ? → betaN+
Duplicate of this bug: 590868
I hope you still love me, Bobby.
Assignee: nobody → bobbyholley+bmo
Confirmed that this is fixed by my patch over in bug 592641. Resolving dupe.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592641
Status: RESOLVED → REOPENED
Depends on: 592641
Resolution: DUPLICATE → ---
(In reply to comment #5)
> Confirmed that this is fixed by my patch over in bug 592641. Resolving dupe.
> 
> *** This bug has been marked as a duplicate of bug 592641 ***

I do not know why this bug was reopened. It seems to be fixed indeed.
It was reopened because it isn't a duplicate (describes a different symptom, better to keep those separate). Bug 592641 fixed it, though, so it can be marked FIXED!
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Target Milestone: mozilla2.0 → mozilla2.0b6
You need to log in before you can comment on or make changes to this bug.