Last Comment Bug 585438 - [SeaMonkey 2.1, mochitest-plain-4, Linux] test_invalidate_during_plugin_paint.html crashing
: [SeaMonkey 2.1, mochitest-plain-4, Linux] test_invalidate_during_plugin_paint...
Status: VERIFIED FIXED
[fixed by bug 545716] [sm-perma][cc-o...
: intermittent-failure
Product: SeaMonkey
Classification: Client Software
Component: Testing Infrastructure (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: seamonkey2.1b1
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: SM-OOPP
Blocks: SmTestFail 580483
  Show dependency treegraph
 
Reported: 2010-08-08 07:02 PDT by Robert Kaiser (not working on stability any more)
Modified: 2012-11-26 02:57 PST (History)
4 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Robert Kaiser (not working on stability any more) 2010-08-08 07:02:19 PDT
test_invalidate_during_plugin_paint.html has been crashing (might be fatal assertion) for a while now on Linux (debug) boxes.

Example log:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1281270793.1281272251.1104.gz

Example output:
2715 INFO TEST-START | /tests/layout/generic/test/test_invalidate_during_plugin_paint.html
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/slave/comm-central-trunk-linux-debug/build/mozilla/extensions/spellcheck/src/mozInlineSpellChecker.cpp, line 1476
++DOMWINDOW == 34 (0x99923d8) [serial = 1026] [outer = 0x9cce7d8]
For application/x-test found plugin libnptest.so
--DOMWINDOW == 33 (0xb6b9e58) [serial = 1004] [outer = 0x9cce7d8] [url = http://mochi.test:8888/tests/layout/generic/test/test_bug468167.html]
--DOMWINDOW == 32 (0xb0e2910) [serial = 1005] [outer = 0x9cce7d8] [url = http://mochi.test:8888/tests/layout/generic/test/test_bug469613.xul]
--DOMWINDOW == 31 (0xb12bc00) [serial = 1006] [outer = 0x9cce7d8] [url = http://mochi.test:8888/tests/layout/generic/test/test_bug469774.xul]
--DOMWINDOW == 30 (0xa6ebd18) [serial = 1002] [outer = 0x9cce7d8] [url = http://mochi.test:8888/tests/layout/generic/test/test_bug448860.html]
--DOMWINDOW == 29 (0xaacda78) [serial = 1024] [outer = 0x9cce7d8] [url = http://mochi.test:8888/tests/layout/generic/test/test_bug522632.html]
--DOMWINDOW == 28 (0xadad300) [serial = 1023] [outer = 0xb82e6a8] [url = about:blank]
--DOMWINDOW == 27 (0xb82e6e0) [serial = 1022] [outer = (nil)] [url = http://mochi.test:8888/tests/layout/generic/test/file_bug514732_1.html]
--DOCSHELL 0xac1e8b0 == 13
--DOMWINDOW == 26 (0xbdb8680) [serial = 1021] [outer = 0xaad31c0] [url = about:blank]
--DOMWINDOW == 25 (0xaad31f8) [serial = 1016] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 24 (0xac292b8) [serial = 1020] [outer = 0xacda910] [url = about:blank]
--DOMWINDOW == 23 (0xacda948) [serial = 1015] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 22 (0xab60dc8) [serial = 1019] [outer = 0xb26c348] [url = about:blank]
--DOMWINDOW == 21 (0xb26c380) [serial = 1014] [outer = (nil)] [url = about:blank]
--DOCSHELL 0xbafeee8 == 12
--DOCSHELL 0xaba7b30 == 11
--DOCSHELL 0xba85098 == 10
--DOMWINDOW == 20 (0xc714660) [serial = 1018] [outer = 0xb1e50e0] [url = about:blank]
--DOMWINDOW == 19 (0xb1e5118) [serial = 1017] [outer = (nil)] [url = http://mochi.test:8888/tests/layout/generic/test/file_bug514732_helper.html]
--DOCSHELL 0xb90be08 == 9
--DOCSHELL 0xc2e0460 == 8
--DOMWINDOW == 18 (0xc6d3020) [serial = 1011] [outer = 0x9cce7d8] [url = http://mochi.test:8888/tests/layout/generic/test/test_bug514732.html]
TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_invalidate_during_plugin_paint.html | Exited with code -11 during test run
INFO | automation.py | Application ran for: 0:24:13.818668
INFO | automation.py | Reading PID log: /tmp/tmpmIzk6Opidlog
WARNING: nsExceptionService ignoring thread destruction after shutdown: file /builds/slave/comm-central-trunk-linux-debug/build/mozilla/xpcom/base/nsExceptionService.cpp, line 197


Last good build:
rev:89de54f97780 / moz:4dd7bbd2ebeb

First bad build:
rev:8b0bbac0f237 / moz:b141a304ad08

Between those all tests have been broken due to some packaging issue, probably in connection to layout. When we came back from the all-tests-breakage, this one remained. Might be connected to the test plugin in some way, as that's loaded before this happens, see http://mxr.mozilla.org/comm-central/source/mozilla/modules/plugin/test/testplugin/ for its code.
Comment 1 Robert Kaiser (not working on stability any more) 2010-08-19 14:55:51 PDT
Can't reproduce this failure locally.

Regression ranges:
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=89de54f97780&tochange=8b0bbac0f237
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=4dd7bbd2ebeb
&tochange=b141a304ad08

Still, may be an issue with the machine setup on our slaves, need to find out about that.
Comment 2 Robert Kaiser (not working on stability any more) 2010-08-19 15:05:11 PDT
Erm, the second range is http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4dd7bbd2ebeb&tochange=b141a304ad08 of course.


I somewhat suspect a connection with bug 571172, which introduced ANGLE but roc also landed large layers stuff in bug 564991 in that range.
Comment 3 Robert Kaiser (not working on stability any more) 2010-09-02 04:49:27 PDT
OK, so I've been informed that ANGLE is only used for webgl right now, which is not connected in any way with this test, so the prime suspect is retained layers.

roc, any idea what's going on there and how we could iron this out? We need to run our SeaMonkey tests on CentOS 5 on VMs right now, just to give you a perspective of what systems this is happening on.
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2010-09-02 04:53:16 PDT
Do you know why there's no stack?
Comment 5 Robert Kaiser (not working on stability any more) 2010-09-02 05:58:24 PDT
(In reply to comment #4)
> Do you know why there's no stack?

No, I wondered myself why there was none, as usually we do have stacks when things crash in tests.
Comment 6 Ian Neal 2010-09-07 15:14:38 PDT
Is it worth sticking a dump command in the checkEnd function to see what PaintCount it is getting and maybe how many times it is looping into that?
Also one in doTest function to see what the initial PaintCount is?
Comment 7 Ian Neal 2010-09-12 10:14:22 PDT
This also happens on Firefox (bug 580483), probably should be duped against that bug.
Comment 8 Ian Neal 2010-09-12 10:15:09 PDT
(Though that times out rather than crashes)
Comment 9 Robert Kaiser (not working on stability any more) 2010-09-15 15:04:10 PDT
For them, there's an intermittent failure, and they clearly get some log output on the plugin doing something, while we don't get any log output but just a crash, and it's permanent. So this seems to be something different.
Comment 10 Treeherder Robot 2010-09-20 06:29:07 PDT
iann_bugzilla%blueyonder.co.uk
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1284986702.1284988493.13189.gz
Rev3 Fedora 12x64 mozilla-central opt test mochitests-4/5 on 2010/09/20 05:45:02

s: talos-r3-fed64-054
11692 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_flush_on_paint.html | Test timed out.
40614 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_mozPaintCount.html | Test timed out.
42056 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_invalidate_during_plugin_paint.html | Test timed out.
134877 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_painting.html | Test timed out.
134878 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | 4 test timeouts, giving up.
134879 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | Skipping 15 remaining tests.
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 11 Robert Kaiser (not working on stability any more) 2010-09-24 03:52:38 PDT
Seems to be fixed by turning on OOPP for SeaMonkey! (bug 545716)

It only ran once since then so far, but as it was really perma-orange, I call it success, and let's reopen when it's still a problem.

And Ian, regarding comment #10, the Firefox case is something else and should be filed as its own bug (though it's possible that we'll hit that one intermittently as well in the future).
Comment 12 Serge Gautherie (:sgautherie) 2010-09-24 05:59:34 PDT
(In reply to comment #11)

Ftr,

First green:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1285315832.1285320698.13046.gz&fulltext=1
Linux comm-central-trunk debug test mochitests-4/5 on 2010/09/24 01:10:32
{
2784 INFO TEST-START | /tests/layout/generic/test/test_invalidate_during_plugin_paint.html
++DOMWINDOW == 18 (0xd4379a0) [serial = 1034] [outer = 0x894f920]
For application/x-test found plugin libnptest.so
2785 INFO TEST-PASS | /tests/layout/generic/test/test_invalidate_during_plugin_paint.html | Got 38 paints
2786 INFO SimpleTest finished /tests/layout/generic/test/test_invalidate_during_plugin_paint.html in 2082ms
}

Next build:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1285328443.1285331848.8616.gz&fulltext=1
Linux comm-central-trunk debug test mochitests-4/5 on 2010/09/24 04:40:43
is orange: passed this test, but timed out and crashed in 2 next tests, fwiw.

V.Fixed, at least ftb.

Note You need to log in before you can comment on or make changes to this bug.