If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

JM: GC interaction with PICs is suboptimal

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
blocker
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: adrake, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The main cause of bugs lately has been:

- The GC frees PICs while they are executing
- The GC frees PICs before they are about to execute, and they don't properly get repatched

Mark bugs/testcases that exhibit this or similar behavior as blocking this so we can keep track.
(Reporter)

Updated

7 years ago
Depends on: 585310
(Reporter)

Updated

7 years ago
Blocks: 585540
(Reporter)

Updated

7 years ago
Blocks: 585310
No longer depends on: 585310
(Reporter)

Updated

7 years ago
No longer blocks: 585310, 585540
Depends on: 585540, 585310
(Reporter)

Comment 1

7 years ago
Apparently caused by PIC reset being wrong, which is now fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.