[tr] Localize the Firefox Home iPhone application strings into Turkish

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: sethb, Assigned: selim)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
The Firefox Home Application for the 1.0.2 release is string frozen and the strings are now loaded in Verbatim.  

http://localize.mozilla.org/projects/fxhome/

You can translate the app using Verbatim, though in this case, you cannot commit directly to the version control system.  Instead, we will take the PO file from Verbatim and convert it back to the original file format.  If you use verbatim, just translate and let us know when you are finished.

If you choose not to use Verbatim, then continue reading.

In Bug 583241, you will find a ZIP containing the files needing localization
for the iPhone Firefox Home application.

Please download that and unzip to see the folders "Strings" and "L10n Strings".
 These folders contain all the files that need l10n.  We will need a copy of
each of the files back with the values of all the entities set to the localized
string.  Please keep the files in UTF-16 encoding.

Specifically, in the "Strings" folder, there is the "English.lproj" folder with
a file called "Localizable.strings".  That file contains the code-based strings
that need translation.  You will see entities like

/* bookmarks menu */
"Bookmarks Menu" = "Bookmarks Menu";

You should translate the string values in the last set of quotations preceding
the semi-colon.  For example, your translation should look like this:

/* bookmarks menu */
"Bookmarks Menu" = "foo bar";

Please translate each entity and save the file in your local folder, not
changing the file name.

In "L10n Strings", you will find several files containing xib-based strings. 
Much like the above, you will see entities in each of these files.  Those
entities look like the following:

/* Class = "IBUIButton"; normalTitle = "Send Me Instructions"; ObjectID = "7";
*/
"7.normalTitle" = "Send Me Instructions";

You should translate the string values in the last set of quotations preceding
the final semi-colon.  For example, your translation should look like this:

/* Class = "IBUIButton"; normalTitle = "Send Me Instructions"; ObjectID = "7";
*/
"7.normalTitle" = "foo bar";

Please translate each entity and save the files in your local folder, not
changing any of the file names.

As you can see, these files look a lot like property files. 

Please reattach a ZIP of all files to this bug when finished.

Further notes of interest:  

All Mac/iPhone localization is done using 'strings' files, which, as just
mentioned, are basically just property files.  All of the localized files get
built into the the binary, and are chosen by matching the ISO 639-1 or 639-2
codes and loading the appropriate file at runtime.

Special request from the dev team:  The size of the strings may be an issue. 
To the extent possible, it would be very helpful if the localized strings were
approximately the same length as the English strings (or shorter).  In many
languages, this will not be realistic, so do the best you can.  

For testing, Dan Walkowsi, copied on this bug, will provide you with a
customized build that you can install on an iPhone.  The dev team is assuming
that someone in your locale has an iPhone to test this app.  If not, please let
us know.
(Reporter)

Comment 1

8 years ago
Your localization is now live in Verbatim.

https://localize.mozilla.org/tr/fxhome/
(Assignee)

Comment 2

8 years ago
Created attachment 464382 [details]
Firefox Home Turkish strings

zip archive attached.
(Reporter)

Comment 3

8 years ago
Thanks, Selim.  I am sending these to Dan Walkowski so he can return a build for testing with instructions on how to install.
(Reporter)

Comment 4

8 years ago
The developer team has discovered a very small set of strings that were missed in the first round of localization because the strings are not actually part of our application.  They are in a small plugin for the OS, which has some advanced settings for Firefox Home.

The file is an XML file where you have to change four strings wrapped in the second set of quotes that serve the value of the English string name.  Example: 

/* this is an example */
"foo" = "foo"

You should translate the second "foo" so that translation might look like this:

/* this is an example */
"foo" = "bar"

Because there are only four strings, we have chosen to send the strings directly via Bugzilla.  The dev team will copy/paste them into the files by hand once we can get them back from the you.

Please translate the following strings in the next comment of this bug.

= Strings =

/* this is a label for the version number of Firefox Home */
"Version" = "Version"

/* this is a warning that this setting should only be used by advanced 
users */
"Caution: use at your own risk" = "Caution: use at your own risk"

/* this is a label for an on/off switch to enable the use of a custom 
Firefox Sync server */
"Use Custom Server" = "Use Custom Server"

/* this is a label for a text field to enter the url of the custom server */
"Server URL" = "Server URL"
(Assignee)

Comment 5

8 years ago
Here they are:

/* this is a label for the version number of Firefox Home */
"Version" = "Sürüm"

/* this is a warning that this setting should only be used by advanced 
users */
"Caution: use at your own risk" = "Uyarı: Kullanım riski size aittir"

/* this is a label for an on/off switch to enable the use of a custom 
Firefox Sync server */
"Use Custom Server" = "Özel sunucu kullan"

/* this is a label for a text field to enter the url of the custom server */
"Server URL" = "Sunucu adresi"
(Reporter)

Comment 6

8 years ago
Thanks for translating this and working so quickly.  Closing this bug as fixed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

8 years ago
Created attachment 468042 [details]
WebPageController.strings update

Please use this one. Thanks.
(Reporter)

Comment 8

8 years ago
Dan, Can you use this updated WebPageController.strings for the Turkish locale?  It has corrections after the Turkish team tested the app.  Thanks.
(Reporter)

Comment 9

8 years ago
Firefox 1.0.3 will ship with some new string changes.  You can find changes here:  https://localize.mozilla.org/projects/fxhome/

It's likely that you read Gandalf's note in the newsgroup.  

http://groups.google.com/group/mozilla.dev.l10n/msg/f9e45c8bd06113f4

I have reopened this bug to track open tasks.  If you have finished the translation, please close this bug.  If you have not finished the work, please close this bug when you are finished.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

8 years ago
Ping.  We will need to gather all of these translations by Wednesday, Sept 29, 17:00 PDT (UTC -7).  Please let me know if you can make it.
(Assignee)

Comment 11

8 years ago
Seth,

We do not have a manager for Turkish at Verbatim so we can't push current Home translations into Verbatim and approve new translations.

If we could arrange someone, I believe I can make it through tomorrow.
(Reporter)

Comment 12

8 years ago
Who is the owner you would like to select?  Selim, you did most of the work last time, correct?  We can give you permissions in Verbatim to approve new translations for Firefox Home.  Please let me know and we'll update the permissions.
(Assignee)

Comment 13

8 years ago
Originally I thought Rail would be fine (see Bug 585920) but I wasn't able to reach him for some time.

Correct, I'm the only one working on Firefox Home at the moment, and I can also take responsibility for it in Verbatim.
(Reporter)

Comment 14

8 years ago
Is your Verbatim user name "selim"?  If you send me that name, I can give you permissions.
(Assignee)

Comment 15

8 years ago
Yes Seth, that's me.
(Reporter)

Comment 16

8 years ago
OK, you now have full permissions on the FxHome project in Verbatim.
(Assignee)

Comment 17

8 years ago
Thanks.

I've just tried updating the files from templates, but nothing came out.

Note that I did NOT use Verbatim before and I've delivered previous Firefox Home translations as strings files. Could that be the cause?
(Reporter)

Comment 18

8 years ago
That is likely the cause. I have added Gandalf to the bug and he can help merge your prior translations into Verbatim.  

Or, you can download the Localizable.strings.po and LoginController.xib.strings.po files from Verbatim, which should contain all the new words needing translation.  If you are using a po tool to translate, it should pick up new words...i think. :)
(Assignee)

Comment 19

8 years ago
Any updates, Gandalf?

When is the deadline, by the way? If we can't solve the Verbatim issue, I may copy and paste everyting into new files or Verbatim. (Unfortunately I didn't use a PO editor for previous translations.)
(Reporter)

Comment 20

8 years ago
Gandalf and I are working on this and will report to you soon.
Hi Selim, apologies for a late response.

I migrated your files to Verbatim and updated it for you. Please, verify that it looks good :)

also, since we gave you permissions to Verbatim pro-forma, it would be awesome to get your Mozilla Contributors Agreement as well so that we know that you accept the open sources licenses we use on our code/localizations :)
(Reporter)

Comment 22

8 years ago
(In reply to comment #21)
> also, since we gave you permissions to Verbatim pro-forma, it would be awesome
> to get your Mozilla Contributors Agreement as well so that we know that you
> accept the open sources licenses we use on our code/localizations :)

I believe Selim sent the contributor agreement last week via email to Erica.  Correct, Selim?
yes, Erica confirmed that she has received Selim's contributors agreement last week, see bug 600511
(Assignee)

Comment 24

8 years ago
Gandalf, now this is the error message I get when I click on "update the files from templates" link:
An error has occurred. Thank you for your patience.
local variable 'output_file' referenced before assignment

Indeed, I've already sent the Contributors Agreement last week.
(Reporter)

Comment 25

8 years ago
I get the same error when I try to update from templates.
fixed now - I forgot to adjust the permissions. Thanks for the heads up :)
(Assignee)

Comment 27

8 years ago
Great!

But I could only see one string to be translated, which was in AboutScreen.xib.strings.po. I thought there were more?
(Reporter)

Comment 28

8 years ago
The two sets of files that needed translation were Localizable.strings.po and LoginController.xib.strings.po.  It seems that the translations were captured there and everything is finished.
(Assignee)

Comment 29

8 years ago
OK, looks like those were "secret phrase" to "Sync Key" changes. We had old translations for those but I updated them manually.

Now I can confirm that Turkish locale is ready for the next version.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.