Mouse move events are ignored when using Visor 2.2 in full screen mode

RESOLVED FIXED

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: peregrino, Assigned: mstange)

Tracking

({regression})

Trunk
All
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 587418])

This is happening when Visor 2.2 (http://visor.binaryage.com/) is installed and running, and Position set (in Preferences panel) to "Full Screen". 
A work around is to set the position to Top-Stretch (i think the default one), though doing that disables the Visor fullscreen.
Please report problems with plug-ins to the author of the plug in.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> Please report problems with plug-ins to the author of the plug in.

Visor is not a plugin for Firefox, is an OSX application. And also, this doesn't happen with Firefox 3.6, it started happening some weeks ago in Minefield, so I think is Minefield's problem, not Visor's...
(Assignee)

Comment 3

8 years ago
Are you on 10.5 or 10.6? Does "some weeks ago" mean that you're testing trunk nightlies? What exactly does "change cursor style properly" mean? That for example moving the mouse over a text field doesn't transform the cursor into an I-beam as expected?

Please state crucial information like this in the initial bug description next time. https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html has some good tips.
Sorry I saw plugins on the referenced web page.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: INVALID → ---
(In reply to comment #3)
> Are you on 10.5 or 10.6? 

I'm on 10.6, and just in case, this was happening before the last update of the
inertial scrolling.

>Does "some weeks ago" mean that you're testing trunk
> nightlies? 

Yes, I'm testing trunk nightlies, I supposed that was implied by using
"Minefield" and labeling this on Trunk. Sorry if it was confusing.

>What exactly does "change cursor style properly" mean? That for
> example moving the mouse over a text field doesn't transform the cursor into an
> I-beam as expected?

Exactly. Also the a:hover styles are not shown and you have to guess where are
the links (as neither the cursor changes to the hand).

> Please state crucial information like this in the initial bug description next
> time. https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html has some good
> tips.

Ok, I'll have it in mind next time. Sorry for the lack of details if that
caused troubles.
(Assignee)

Comment 6

8 years ago
Thanks. I think I caused this bug with the changes in bug 300904 and bug 557986.
Assignee: nobody → mstange
Status: UNCONFIRMED → ASSIGNED
Component: General → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → cocoa
Hardware: x86 → All
(Assignee)

Updated

8 years ago
Summary: Minefield doesn't change cursor style properly → Mouse move events are ignored when using Visor 2.2 in full screen mode
(Assignee)

Updated

8 years ago
Blocks: 300904, 557986
(Assignee)

Updated

8 years ago
Keywords: regression
(Assignee)

Comment 7

8 years ago
The patch in bug 587418 also fixes this bug.
Depends on: 587418
(Assignee)

Comment 8

8 years ago
Fixed by bug 587418.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 587418]
This is not fixed, or I found another bug. Steps to reproduce:

1) Set Visor to appear in Full Screen.
2) Open Firefox, toggle full screen mode.
3) Open 2 tabs
4) Open visor (it should appear in full screen)
5) Leave hide visor, and return to firefox
6) leave firefox full screen mode
7) try to change tabs

expected:
That in step 7 you could change tabs, and keep browsing

seen:
nothing happens, unless you return to full screen mode in firefox (where it behaves correctly) or set visor to not appear full screen.

Updated

8 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

8 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 10

8 years ago
(In reply to comment #9)
> 7) try to change tabs

How? By clicking on them? If so, does clicking stop working completely? Or only in certain parts of the Firefox window?
Status: ASSIGNED → NEW
(In reply to comment #10)
> How? By clicking on them? If so, does clicking stop working completely? Or only
> in certain parts of the Firefox window?

Is weird, is more like the repainting of the screen is not happening. I can right click in everywhere, so I tried this simple steps:

1) Do the previous mentioned steps 1 - 7
2) Right click on the content area of the newly switched tab.
4) right click again on a different point of the content area.

You'll see that the content area below the context menu is being repainted, but not the rest.

Also, I think something similar happens with full screen sharing in skype for mac, but I don't have a test case for that.
(Assignee)

Comment 12

8 years ago
OK, that's definitely a different bug, probably bug 603134. Can you add your steps to reproduce there, please?

I'll resolve this bug again because the original issue is fixed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(In reply to comment #12)
> OK, that's definitely a different bug, probably bug 603134. Can you add your
> steps to reproduce there, please?
> 

Ok I'll add myself on CC to follow the changes, but I don't know what to say there. The only way I find this happening is when I have something else as full screen (like visor or skype screen sharing).
You need to log in before you can comment on or make changes to this bug.