ecma/TypeConversion/9.5-2.js fails on Windows 64-bit

RESOLVED DUPLICATE of bug 597814

Status

()

defect
RESOLVED DUPLICATE of bug 597814
9 years ago
7 years ago

People

(Reporter: dbaron, Assigned: m_kato)

Tracking

({intermittent-failure})

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281357827.1281359049.19738.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/mozilla-central_w764_test-jsreftest/build/jsreftest/tests/jsreftest.html?test=ecma/TypeConversion/9.5-2.js | Number.MIN_VALUE << 0 wrong value  item 8
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/mozilla-central_w764_test-jsreftest/build/jsreftest/tests/jsreftest.html?test=ecma/TypeConversion/9.5-2.js | -Number.MIN_VALUE << 0 wrong value  item 9

This is probably a persistent failure, but these tests only run once per day.  We didn't see this before because the jsreftest run was not completing prior to the landing of bug 582910, so this is the first run where it was observed.
Posted patch fixSplinter Review
Assignee: general → m_kato
Comment on attachment 465572 [details] [diff] [review]
fix

Use emulation instead of on Win64 due to fmod bug
Attachment #465572 - Flags: review?(jorendorff)
Comment on attachment 465572 [details] [diff] [review]
fix

I endorse the approach, but Jim might have an opinion on the best way of saying "...or we're on Windows x64".

Thanks to dbaron for noticing and filing this.
Attachment #465572 - Flags: review?(jorendorff) → review?(jim)
(In reply to comment #4)
> I endorse the approach, but Jim might have an opinion on the best way of saying
> "...or we're on Windows x64".

I suspect this would result in adding only  MSVC-on-x86_64 to that case, but if that's the intent, it might be good to clarify it by checking for _MSC_VER as well.  If it's not the intent, you probably want to check for __x86_64 and/or __x86_64__ (gcc defines both).
Applying the hotfix instead is not an option?
Attachment #465572 - Flags: review?(jim)
pass jsreftest
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1285768446.1285769737.23777.gz
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 597814
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.