Last Comment Bug 585849 - Firefox 4.0b2 Crash Report [@ mozilla::`anonymous namespace''::ContainerState::ProcessDisplayItems(nsDisplayList const&, nsRect const*) ]
: Firefox 4.0b2 Crash Report [@ mozilla::`anonymous namespace''::ContainerState...
Status: RESOLVED FIXED
: crash, regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on: 556487
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 20:33 PDT by chris hofmann
Modified: 2011-11-21 21:44 PST (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments

Description chris hofmann 2010-08-09 20:33:01 PDT
possible new crash in 4.0betas

http://crash-stats.mozilla.com/report/index/832bbe1b-57cd-4986-b232-31a452100802

0  	xul.dll  	mozilla::`anonymous namespace'::ContainerState::ProcessDisplayItems  	 layout/base/FrameLayerBuilder.cpp:939
1 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::ProcessDisplayItems 	layout/base/FrameLayerBuilder.cpp:853
2 	xul.dll 	mozilla::FrameLayerBuilder::BuildContainerLayerFor 	layout/base/FrameLayerBuilder.cpp:1173
3 	xul.dll 	nsDisplayList::PaintForFrame 	layout/base/nsDisplayList.cpp:394
4 	xul.dll 	nsLayoutUtils::PaintFrame 	layout/base/nsLayoutUtils.cpp:1343
5 	xul.dll 	PresShell::Paint 	layout/base/nsPresShell.cpp:5904
6 	xul.dll 	nsViewManager::RenderViews 	view/src/nsViewManager.cpp:448
7 	xul.dll 	nsViewManager::Refresh 	view/src/nsViewManager.cpp:414
8 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:843
9 	xul.dll 	HandleEvent 	view/src/nsView.cpp:160
10 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3564
11 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:3592
12 	xul.dll 	nsWindow::OnPaint 	widget/src/windows/nsWindowGfx.cpp:563
13 	xul.dll 	xul.dll@0x41fe4e 	
14 		@0x7f

more reports at http://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&date=2010-08-09%2018%3A00%3A00&signature=mozilla%3A%3A%60anonymous%20namespace%27%27%3A%3AContainerState%3A%3AProcessDisplayItems%28nsDisplayList%20const%26%2C%20nsRect%20const*%29&version=Firefox%3A4.0b2

might be winXP only.  looks like it firt started showing up with 1 crash around July 18.  bump in volume around Aug 1 and currently running at about 26 crashes per day.

checking --- mozilla::.anonymous.namespace..::ContainerState::ProcessDisplayItems.nsDisplayList 20100808-crashdata.csv
found in: 4.0b2
release total-crashes
              mozilla::.anonymous.namespace..::ContainerState::ProcessDisplayItems.nsDisplayList crashes
                         pct.
all  	258682	26	0.00010051
4.0b2	12959	26	0.00200633

os breakdown
mozilla::.anonymous.namespace..::ContainerState::ProcessDisplayItems.nsDisplayListTotal 20
Win5.1  1.00
Win6.0  0.00
Win6.1  0.00
Mac10.4 0.00
Mac10.5 0.00
Mac10.6 0.00
Lin2.4  0.00
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2010-09-07 20:38:55 PDT
Hopefully fixed by bug 556487, but we're not going to block without a testcase, I think.
Comment 2 chris hofmann 2010-09-07 21:15:25 PDT
turned out to be low volume on b4;  ~ #94 topcrash.  but we should be able to confirm the fix for bug 556487 if it lands in b6.
Comment 3 Sheila Mooney 2011-11-21 21:44:28 PST
We never resolved it was fixed. Not appearing in anything after 4.0b6.

Note You need to log in before you can comment on or make changes to this bug.