check-math-partial-sums.js failed with JIT on SPARC

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Ginn Chen, Assigned: Leon Sha)

Tracking

Trunk
Sun
OpenSolaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-nanojit, fixed-in-tamarin)

Attachments

(1 attachment, 1 obsolete attachment)

4.74 KB, patch
William Maddox
: review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
It fails before fatval is landed, so it is not a recent regression.
(Assignee)

Comment 1

8 years ago
Created attachment 464716 [details] [diff] [review]
patch

Use smulcc instead of mulx to handle multiply overflow. Overflow after SMUL / SMULcc is indicated by Y not equal to (r[rd] >> 31), where “>>” indicates 32-
bit arithmetic right shift.
Assignee: general → leon.sha
Status: NEW → ASSIGNED
Attachment #464716 - Flags: review?(edwsmith)

Updated

8 years ago
Attachment #464716 - Flags: review?(edwsmith) → review?(wmaddox)

Comment 2

8 years ago
Comment on attachment 464716 [details] [diff] [review]
patch

+                else if (op == LIR_muli || op == LIR_mulxovi || op == LIR_muljovi) {
+                    SUBCC(L4, L6, L4);
+                    SRAI(rr, 31, L6);
+                    RDY(L4);
+                    SMULCC(rr, rb, rr);

R-: It looks like you are making LIR_muli, which need not be checked for overflow, pay the cost of three additional instructions.
Attachment #464716 - Flags: review?(wmaddox) → review-
(Assignee)

Comment 3

8 years ago
Created attachment 465060 [details] [diff] [review]
patch
Attachment #464716 - Attachment is obsolete: true
Attachment #465060 - Flags: review?(wmaddox)

Updated

8 years ago
Attachment #465060 - Flags: review?(wmaddox) → review+
(Assignee)

Comment 4

8 years ago
http://hg.mozilla.org/projects/nanojit-central/rev/eceee9526737
Whiteboard: fixed-in-nanojit

Comment 5

8 years ago
TR: http://hg.mozilla.org/tamarin-redux/rev/33cdfe09d57e
Whiteboard: fixed-in-nanojit → fixed-in-nanojit, fixed-in-tamarin

Comment 6

8 years ago
http://hg.mozilla.org/mozilla-central/rev/ae07d3052ab5
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.