Closed Bug 585974 Opened 10 years ago Closed 10 years ago

Task dialog doesn't remember and restore previous size and position but uses default ones

Categories

(Calendar :: Dialogs, defect)

Lightning 1.0b2
x86
All
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 394195

People

(Reporter: mac80, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.7) Gecko/20100713 Lightning/1.0b2 Thunderbird/3.1.1

check the URL given - it shows that new tasks always appear in the wrong width. it is possible to resize them manually, but the next tasks will be the old (too small) width again.

Reproducible: Always

Steps to Reproduce:
1.Make new task for lightning calendar
Attached image screenshot
Component: General → Lightning Only
Product: Thunderbird → Calendar
QA Contact: general → lightning
Version: unspecified → Lightning 1.0b2
The same issue exists on Mac: http://bugs.aviary.pl/attachment.cgi?id=1606
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-calendar1.0?
OS: Linux → All
Yes, it is a regression from Bug 491207. 

Due to the patch for Bug 491207 the Dialog-ID is changed during runtime from "calendar-event-dialog" to "calendar-task-dialog". <http://mxr.mozilla.org/comm-central/source/calendar/base/content/dialogs/calendar-event-dialog.js#156>

When closing the dialog its size and position are stored for "calendar-task-dialog". But when opening the dialog size and position are restored for "calendar-event-dialog". This is the reason why the task dialog always has the same size as the event dialog.
Component: Lightning Only → Dialogs
QA Contact: lightning → dialogs
The same issue exists on:
Windows XP SP3
Thunderbird 3.1.7
Lightning 1.0b2

Exists any solution? is solved for nightly builds?
Blocks: 491207
Keywords: regression
Summary: New task in Lightning always appears in wrong size → Task dialog doesn't remember and restore previous size and position but uses default ones
This should be fixed in bug 394195, if we agree on a solution.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394195
Flags: wanted-calendar1.0?
You need to log in before you can comment on or make changes to this bug.