Cant open the Web Console: (NS_ERROR_XPC_JS_THREW_JS_OBJECT) & (NS_ERROR_INVALID_POINTER)

RESOLVED INVALID

Status

RESOLVED INVALID
8 years ago
2 months ago

People

(Reporter: aaronmt, Assigned: msucan)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Reporter)

Description

8 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre

STR:

1. Open a tab, and hit a website such as http://news.ycombinator.com
2. Open a tab, and hit a website such as http://www.rogers.com
3. Enter PB Mode
4. Exit PB Mode
5. Hit cmd-shift-K

ER: Web console opens up
AR: Web console does not open

See error console:

Error: [Exception... "'Error: Cannot get outputNode by id' when calling method: [nsIConsoleListener::observe]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "<unknown>"  data: no]

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: resource://gre/modules/HUDService.jsm :: HS_getStr :: line 129"  data: no]
Source File: resource://gre/modules/HUDService.jsm
Line: 129
(Reporter)

Updated

8 years ago
Summary: Cant open the Web Console "Error: Cannot get outputNode by id" (NS_ERROR_XPC_JS_THREW_JS_OBJECT) → Cant open the Web Console "Error: Cannot get outputNode by id" (NS_ERROR_XPC_JS_THREW_JS_OBJECT) & (NS_ERROR_INVALID_POINTER)
(Reporter)

Updated

8 years ago
Summary: Cant open the Web Console "Error: Cannot get outputNode by id" (NS_ERROR_XPC_JS_THREW_JS_OBJECT) & (NS_ERROR_INVALID_POINTER) → Cant open the Web Console: (NS_ERROR_XPC_JS_THREW_JS_OBJECT) & (NS_ERROR_INVALID_POINTER)
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
blocking2.0: ? → final+

Comment 1

8 years ago
This is a problem with L10N. The property name is not found. This happened before, but I cannot remember which bug.

Updated

8 years ago
Assignee: nobody → ddahl

Comment 2

8 years ago
I cannot reproduce this with Mozilla/5.0 (X11; Linux i686; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> I cannot reproduce this with Mozilla/5.0 (X11; Linux i686; rv:2.0b4pre)
> Gecko/20100810 Minefield/4.0b4pre

After step 5, have the open error console open and try entering and exiting PB mode again

Updated

8 years ago
Severity: major → blocker
(Reporter)

Comment 4

8 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6pre) Gecko/20100903 Firefox/4.0b6pre

Error: [Exception... "'Error: FAH_getOutputNodeById: id is null!!' when calling method: [nsIConsoleListener::observe]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "<unknown>"  data: no]

Comment 5

8 years ago
Reprioritizing bugs. You can filter the mail on the word TEABAGS.
Severity: blocker → normal
Whiteboard: [kd4b7]

Updated

8 years ago
Blocks: 594225

Updated

8 years ago
Assignee: ddahl → mihai.sucan

Updated

8 years ago
Whiteboard: [kd4b7]
(Assignee)

Comment 6

8 years ago
I cannot reproduce this issue. I use Ubuntu 10.04, 64 bits:

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100922 Firefox/4.0b7pre

(local build, pulled today from m-c).

Aaron: can you still reproduce the error?

I would note that I follow the original STR. Which means that the Web Console can open after having went into PB and out of it.

I presume you bumped into bug 583476 which prevented the Web Console from opening on web sites which overwrite the window.console object (that's the case with rogers.com and quite some more sites). This is now fixed.

The other error you're seeing is bug 597151. When the Web Console is open and then closed we do not remove the nsIConsoleListener we have, and the listener tries to output messages in the Web Console which is no longer open. Rogers.com spews many errors and that's how you see those errors when returning from PB.

Lastly, at the moment it is expected that the Web Console doesn't return to its open state once you're back from PB. If this is desired, I believe we should file a separate report.

Thanks!
(Reporter)

Comment 7

8 years ago
It's been a while, using my STR in comment #0, I can no longer reproduce the error - although I do get 

13:18:19.108: The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this page.
(Assignee)

Comment 8

8 years ago
(In reply to comment #7)
> It's been a while, using my STR in comment #0, I can no longer reproduce the
> error - although I do get 
> 
> 13:18:19.108: The Web Console logging API (console.log, console.info,
> console.warn, console.error) has been disabled by a script on this page.

Indeed, and this is expected, as per bug 583476. We are warning the user that the web page has overwritten the window.console object and that our WebConsole API is not going to be available. (we do not overwrite author-provided window.console objects)
can we close this then?

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.