Dataloss when updating TEXTAREA value when display:none is set

RESOLVED DUPLICATE of bug 57269

Status

()

Core
Layout: Form Controls
P3
critical
RESOLVED DUPLICATE of bug 57269
18 years ago
17 years ago

People

(Reporter: djoham, Assigned: rubydoo123)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-15mdk i686; en-US; m18) Gecko/20001030
BuildID:    20001030

If you update the value of a textarea when it's wrapped in a div with display:
none set, the new value will be lost when the DIV is made visible again


Reproducible: Always
Steps to Reproduce:
Open test case I'll submit. Follow instructions	

Actual Results:  the value the textarea had before it was made invisible is
returned when it is made visible again, even if that value has changed via javascript.	


Expected Results:  the   textarea should retain the value I give it, no matter
what happens to it.

IE renders as I would expect
Textboxes render as I would expect (even in mozilla).


This bug causes dataloss since updates to hidden textareas are lost when that
textarea is made visible again.

This bug is critical for the above reason and since the workaround (saving
values and resetting them after the textarea is unhidden) is really hokey and
very prone to error. Plus it makes us look silly
(Reporter)

Comment 1

18 years ago
Created attachment 18382 [details]
test case
Changing to HTML Form Controls and confirming.  The textarea's value is part of
the DOM, so it should be stored in the DOM (not the frames).  That's what having
a DOM implementation means, right?
Assignee: clayton → rods
Status: UNCONFIRMED → NEW
Component: HTML Element → HTML Form Controls
Ever confirmed: true
QA Contact: lorca → bsharma

Comment 3

18 years ago
this is a dup, reassigning
Assignee: rods → beppe
duplicate

*** This bug has been marked as a duplicate of 57269 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.