Closed Bug 586183 Opened 10 years ago Closed 10 years ago

e10s merge caused bustage for --disable-ipc in embedding/

Categories

(Core :: IPC, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b4

People

(Reporter: Callek, Assigned: dougt)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Attached patch Fix (obsolete) — Splinter Review
../webBrowser/libnsWebBrowser_s.a(nsWebBrowser.o): In function `nsWebBrowser::Create()':
/builds/slave/comm-central-trunk-linux64/build/mozilla/embedding/browser/webBrowser/nsWebBrowser.cpp:1236: undefined reference to `XRE_GetProcessType'
collect2: ld returned 1 exit status

Patch by mfinkle. Doug asked to assign to him, this way if no-one pushes by tomorrow morning, he will.

[Whoever pushes, feel free to change commit message to something more meaningful, e.g. including this bug #]
Attachment #464708 - Flags: review?(doug.turner)
Attachment #464708 - Flags: approval2.0?
Attachment #464708 - Flags: review?(doug.turner) → review-
tracking-fennec: --- → ?
the patch should be:

#ifdef MOZ_IPC
   if (XRE_GetProcessType() == GeckoProcessType_Default)
#endif
   {
       // Hook up global history. Do not fail if we can't - just warn.                                                                                                              
       rv = EnableGlobalHistory(mShouldEnableHistory);
       NS_WARN_IF_FALSE(NS_SUCCEEDED(rv), "EnableGlobalHistory() failed");
   }
tracking-fennec: ? → ---
Attached patch real fixSplinter Review
Lets try attaching again, this time creating my MQ against the right tree.
Attachment #464708 - Attachment is obsolete: true
Attachment #464711 - Flags: review?(doug.turner)
Attachment #464711 - Flags: approval2.0?
Attachment #464708 - Flags: approval2.0?
Duplicate of this bug: 586273
Attachment #464711 - Flags: review?(doug.turner)
Attachment #464711 - Flags: review+
Attachment #464711 - Flags: approval2.0?
Attachment #464711 - Flags: approval2.0+
Isn't so that we can call XRE_GetProcessType in non IPC builds?
it should just return GeckoProcessType_Default always

http://mxr.mozilla.org/mozilla-central/source/toolkit/xre/nsAppRunner.cpp#3837
I'm surprised it isn't #defined away in non-ipc builds.
(In reply to comment #4)
> Isn't so that we can call XRE_GetProcessType in non IPC builds?
> it should just return GeckoProcessType_Default always
> 
> http://mxr.mozilla.org/mozilla-central/source/toolkit/xre/nsAppRunner.cpp#3837

The problem in shared builds is that nsAppRunner is built after embedding/ iirc
Pushed the attached patch as
http://hg.mozilla.org/mozilla-central/rev/9b4466b55eaf

Oleg, if that's true, please let go into a followup, as this was something we
needed to fix heavy bustage on Thunderbird and SeaMonkey trees.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b4
You need to log in before you can comment on or make changes to this bug.