Build failure in LayerManagerD3D9 due to --disable-ipc not also defining Unicode

RESOLVED FIXED in mozilla2.0b4

Status

()

Core
IPC
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Callek, Assigned: Callek)

Tracking

({regression})

Trunk
mozilla2.0b4
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 464712 [details] [diff] [review]
fix

When LayerManagerD3D9 is compiled, the makefile (if MOZ_IPC) ends up defining UNICODE, which is fine. However the code involved assumes the unicode version of CreateWindow is utilized.

This fails in a --disable-ipc build due to the non-unicode version of CreateWindow getting used, and thus a paramater conversion error.  This patch just uses CreateWindowW directly.

the patch has rs+=khuey over IRC, requesting here for posterity.

Whoever pushes feel free to update the commit message in a sane way (e.g. include the bug # of this bug)
Attachment #464712 - Flags: review?(me)
Attachment #464712 - Flags: approval2.0?
Comment on attachment 464712 [details] [diff] [review]
fix

>-  mFocusWnd = CreateWindow(kClassName, L"D3D9Window", WS_OVERLAPPEDWINDOW,
>+  mFocusWnd = ::CreateWindowW(kClassName, L"D3D9Window", WS_OVERLAPPEDWINDOW,
>                            CW_USEDEFAULT, 0, CW_USEDEFAULT, 0, NULL,
>                            NULL, GetModuleHandle(NULL), NULL);

Nit: line the continuations of the call up again.

rs=me (though this isn't really my code.)

Could you file a Core::Build Config followup on AC_DEFINEing UNICODE?

FWIW, I also don't think this needs approval since it's a bustage fix.
Attachment #464712 - Flags: review?(me) → review+

Comment 2

8 years ago
Pushed as http://hg.mozilla.org/mozilla-central/rev/41b686bb548a
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b4

Updated

8 years ago
Attachment #464712 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 3

8 years ago
(In reply to comment #1)
> Could you file a Core::Build Config followup on AC_DEFINEing UNICODE?

Filed Bug 589370
You need to log in before you can comment on or make changes to this bug.