Backup-ing bookmarks produces invalid JSON

RESOLVED DUPLICATE of bug 505656

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 505656
8 years ago
8 years ago

People

(Reporter: radko.dinev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8

When I exported my bookmarks the file had the following format:

{"title":"","id":1,"dateAdded":1278869559086000,"lastModified":1279009682991523,"type":"text/x-moz-place-container","root":"placesRoot","children":[{},{},{},]}

There is one extra comma in the "children" array (the last one) which makes the JSON invalid. I tested on two different sets of bookmark entries and happened on both of them. So it is a bookmark-independent problem, I guess.


Reproducible: Always
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Updated

8 years ago
Version: 3.6 Branch → unspecified

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 505656
You need to log in before you can comment on or make changes to this bug.