If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The IE9 Fish Demo runs really slow.

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: streetwolf, Assigned: bas)

Tracking

(Blocks: 2 bugs, {regression})

Trunk
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ietestdrive, URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre
Build Identifier: 20100811040838


http://hg.mozilla.org/mozilla-central/rev/20ab6d450abc or thereabouts seems to be the cause.

Reproducible: Always
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
(Reporter)

Updated

7 years ago
Keywords: regression
(Assignee)

Updated

7 years ago
Assignee: nobody → bas.schouten
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 1

7 years ago
Hrm, at first sight I can't see anything going wrong. But I can reproduce the performance problem, we'll need to find out which revision regressed this. None of the added code seems to be getting used here.
(Reporter)

Comment 2

7 years ago
Bas.  I can't seem to find the regression.  I know there was similar problem in the past and based on a post on Mozillazine this was fixed around 7/31.  I did notice the demo was even slower around this date however all the hourlys from the 31st forward still produce a slow demo.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre - Build ID: 20100811040838
I'm also seeing this on my fairly new i7 computer with an Nvidia geForce GTS 250 GPU - it's been a while since I looked at this demo so I'm unable to give a rough idea of when it started.

If you find a patch and need testers for a trserver build or whatnot, let us know. It seems some people can see this and others cannot - not sure exactly why that is.
(Reporter)

Comment 4

7 years ago
At 500 fish I get ~30fps.  At 1000 fish ~ 20 FPS.

If I run in safemode this goes up.  500 fish ~42fps. 1000fish ~ 30fps.

When I run with a new profile I still have the lower numbers.  Is there something in Prefs causing this?  I have the 2 d2d/dw optins set correctly.

And like Ryan above I really can't remember the last time I ran the demo before today.
(Assignee)

Comment 5

7 years ago
(In reply to comment #2)
> Bas.  I can't seem to find the regression.  I know there was similar problem in
> the past and based on a post on Mozillazine this was fixed around 7/31.  I did
> notice the demo was even slower around this date however all the hourlys from
> the 31st forward still produce a slow demo.
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810
> Minefield/4.0b4pre - Build ID: 20100811040838

So might they have adjusted the demo?
(Assignee)

Comment 6

7 years ago
I get similar results in the IE Platform Preview compared to our latest builds.
(Reporter)

Comment 7

7 years ago
(In reply to comment #5)
> (In reply to comment #2)
> > Bas.  I can't seem to find the regression.  I know there was similar problem in
> > the past and based on a post on Mozillazine this was fixed around 7/31.  I did
> > notice the demo was even slower around this date however all the hourlys from
> > the 31st forward still produce a slow demo.
> > 
> > Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810
> > Minefield/4.0b4pre - Build ID: 20100811040838
> 
> So might they have adjusted the demo?

If so, how to explain the better performance in safemode and the same performance with a new profile?
(Assignee)

Comment 8

7 years ago
(In reply to comment #7)
> (In reply to comment #5)
> > (In reply to comment #2)
> > > Bas.  I can't seem to find the regression.  I know there was similar problem in
> > > the past and based on a post on Mozillazine this was fixed around 7/31.  I did
> > > notice the demo was even slower around this date however all the hourlys from
> > > the 31st forward still produce a slow demo.
> > > 
> > > Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810
> > > Minefield/4.0b4pre - Build ID: 20100811040838
> > 
> > So might they have adjusted the demo?
> 
> If so, how to explain the better performance in safemode and the same
> performance with a new profile?

I agree that that's interesting but it's not something I tested in the past! So it might be something that's always there but we simply didn't test, I see the same 6-10% better performance than the IE 9 platform preview that I've always seen though.
The safemode doesn't only disable the addons/themes, it also disables the jit
This is pretty much that I see when I view the page, though the value fluctuates massivly - sometimes it is 34-ish and others it is this and below.

This was with a new profile, just with D2D enabled.

http://sciguyryan.com/wp-content/uploads/2010/08/FishTank.png
(Assignee)

Comment 11

7 years ago
(In reply to comment #9)
> The safemode doesn't only disable the addons/themes, it also disables the jit

Interesting that it runs faster -without- the jit. Isn't it?

(In reply to comment #10)
> This is pretty much that I see when I view the page, though the value
> fluctuates massivly - sometimes it is 34-ish and others it is this and below.
> 
> This was with a new profile, just with D2D enabled.
> 
> http://sciguyryan.com/wp-content/uploads/2010/08/FishTank.png

That's really slow.. are you sure D2D is working?
(In reply to comment #11)
> (In reply to comment #10)
> > This is pretty much that I see when I view the page, though the value
> > fluctuates massivly - sometimes it is 34-ish and others it is this and below.
> > 
> > This was with a new profile, just with D2D enabled.
> > 
> > http://sciguyryan.com/wp-content/uploads/2010/08/FishTank.png
> 
> That's really slow.. are you sure D2D is working?

Now there is interesting. D2D is turned on (rendermode is set to 6) and yet about:memory is showing:

gfx/d2d/surfacecache 0

Or is that correct?
(Reporter)

Comment 13

7 years ago
(In reply to comment #9)
> The safemode doesn't only disable the addons/themes, it also disables the jit

I disabled Web Jit and sure enough my speeds increased without using safemode.  I suppose a new profile enables Jit which is why I see the same drop in performance with a new profile?
(Assignee)

Comment 14

7 years ago
(In reply to comment #12)
> (In reply to comment #11)
> > (In reply to comment #10)
> > > This is pretty much that I see when I view the page, though the value
> > > fluctuates massivly - sometimes it is 34-ish and others it is this and below.
> > > 
> > > This was with a new profile, just with D2D enabled.
> > > 
> > > http://sciguyryan.com/wp-content/uploads/2010/08/FishTank.png
> > 
> > That's really slow.. are you sure D2D is working?
> 
> Now there is interesting. D2D is turned on (rendermode is set to 6) and yet
> about:memory is showing:
> 
> gfx/d2d/surfacecache 0
> 
> Or is that correct?

Theoretically it's possible, but it is highly unlikely, did you remember to turn on DirectWrite as well? Otherwise it will fallback to GDI.
(In reply to comment #14)
> 
> Theoretically it's possible, but it is highly unlikely, did you remember to
> turn on DirectWrite as well? Otherwise it will fallback to GDI.

I can confirm that DirectWrite is enabled and render mode is set to 6.
(Reporter)

Comment 16

7 years ago
fwiw on my system gfx/d2d/surfacecache = 20,772,628
(Assignee)

Comment 17

7 years ago
(In reply to comment #15)
> (In reply to comment #14)
> > 
> > Theoretically it's possible, but it is highly unlikely, did you remember to
> > turn on DirectWrite as well? Otherwise it will fallback to GDI.
> 
> I can confirm that DirectWrite is enabled and render mode is set to 6.

Okay, what kind of hardware is this on? Any add-on's running? Those can in some cases break stuff.
(In reply to comment #17)
> (In reply to comment #15)
> > (In reply to comment #14)
> > > 
> > > Theoretically it's possible, but it is highly unlikely, did you remember to
> > > turn on DirectWrite as well? Otherwise it will fallback to GDI.
> > 
> > I can confirm that DirectWrite is enabled and render mode is set to 6.
> 
> Okay, what kind of hardware is this on? Any add-on's running? Those can in some
> cases break stuff.

Hardware is an Intel i7-930 processor with an Nvidia GeForce GTS 250 GPU. I created a new profile to test this, as well as my working profile - both show the same result, as such its probably not an addon issue.

Since I only have ABP installed on this (the work profile) anyway, its pretty easy to filter that out.
(Assignee)

Comment 19

7 years ago
(In reply to comment #18)
> (In reply to comment #17)
> > (In reply to comment #15)
> > > (In reply to comment #14)
> > > > 
> > > > Theoretically it's possible, but it is highly unlikely, did you remember to
> > > > turn on DirectWrite as well? Otherwise it will fallback to GDI.
> > > 
> > > I can confirm that DirectWrite is enabled and render mode is set to 6.
> > 
> > Okay, what kind of hardware is this on? Any add-on's running? Those can in some
> > cases break stuff.
> 
> Hardware is an Intel i7-930 processor with an Nvidia GeForce GTS 250 GPU. I
> created a new profile to test this, as well as my working profile - both show
> the same result, as such its probably not an addon issue.
> 
> Since I only have ABP installed on this (the work profile) anyway, its pretty
> easy to filter that out.

In the past ABP was problematic with D2D. Not sure if it still is.
(In reply to comment #19)
> 
> In the past ABP was problematic with D2D. Not sure if it still is.

The new profile doesn't have it so it can't be that in any event, both profiles give the same results.
> I disabled Web Jit and sure enough my speeds increased without using safemode. 

Can you please file a separate js engine bug?
(Assignee)

Comment 22

7 years ago
(In reply to comment #21)
> > I disabled Web Jit and sure enough my speeds increased without using safemode. 
> 
> Can you please file a separate js engine bug?

We just received a report of D2D not working on several machines. We're investigating now.
(Reporter)

Comment 23

7 years ago
(In reply to comment #22)
> (In reply to comment #21)
> > > I disabled Web Jit and sure enough my speeds increased without using safemode. 
> > 
> > Can you please file a separate js engine bug?
> 
> We just received a report of D2D not working on several machines. We're
> investigating now.

Do you still want me to file a jit bug report Bas?
Yes please - the jit should never be slower than not jitting!

Updated

7 years ago
Whiteboard: ietestdrive
I did a few tests on my Nvidia 7050 (DX9) with 20 fish, including with most recent trunk.  about:memory : gfx/d2d/surfacecache = 0 with DW/D2D on.  

Some figures:

3.6.8  - 25 fps

4b1 - DW/D2D on - was really slow like 3 fps
4b1 - DW/D2D off -  20-23 fps

4b3 - DW/D2D on - was so slow it locked up the browser, barely 1 fps.
4b3 - DW/D2D off - 20 fps

4.0b4pre - D2D/DW on - 20 fps
4.0b4pre - DW/D2D off - 20 fps

4.0b4pre - D2D/DW on:
Background tab speed, fish become way more active! 30-50 fps
Foreground tab speed: 20 fps.

4.0b4pre - D2D/DW off:
Background tab speed, fish become way more active! 30-60 fps
Foreground tab speed: 20 fps.
(Assignee)

Comment 26

7 years ago
(In reply to comment #25)
> I did a few tests on my Nvidia 7050 (DX9) with 20 fish, including with most
> recent trunk.  about:memory : gfx/d2d/surfacecache = 0 with DW/D2D on.  
> 
> Some figures:
> 
> 3.6.8  - 25 fps
> 
> 4b1 - DW/D2D on - was really slow like 3 fps
> 4b1 - DW/D2D off -  20-23 fps
> 
> 4b3 - DW/D2D on - was so slow it locked up the browser, barely 1 fps.
> 4b3 - DW/D2D off - 20 fps
> 
> 4.0b4pre - D2D/DW on - 20 fps
> 4.0b4pre - DW/D2D off - 20 fps
> 
> 4.0b4pre - D2D/DW on:
> Background tab speed, fish become way more active! 30-50 fps
> Foreground tab speed: 20 fps.
> 
> 4.0b4pre - D2D/DW off:
> Background tab speed, fish become way more active! 30-60 fps
> Foreground tab speed: 20 fps.

I don't think you're getting D2D support. Check 'about:support' to see if its getting enabled on your last builds.
It does say false all the time with the last builds, also not seeing testcase from bug 532106 after 8-10.
D2D / D3D9 hardware is working again in nightly 8-19.  I see on my system, 1 FishIE tab was using about 4 megs of vram, still high CPU (Core 2 Duo) this time with DW/D2D on I see about 15 fps at first, then it slowly dropped down to about 9 fps and stayed there.
Looks like I get about 2 fps with 20 fish, d2d/dw/d3d9 enabled: --> slowui
Blocks: 599546

Comment 30

7 years ago
Is this still an issue?  I am using the latest Nightly (11/28/10 Build) with default graphics settings and am seeing 60 fps on all numbers of fish in tank except 1000, where the fps drops to about 30.  My screen size (according to Fish Tank Page is 1366 x 629 without Minefield full-screen mode and 1366 x 767 in full-screen mode.  I receive the same fps for all fish sizes in both screen modes and have an NVIDIA 9800M GS Laptop chipset.

Comment 31

7 years ago
In latest Minefield, 17fps/1000 in Minefield and Google Chrome, both got almost same FPS.
However, Minefield seem to skip with a frame like a hiccup every 1-2 seconds.

Comment 32

7 years ago
Gary,
Is it OK for you now?
(Reporter)

Comment 33

7 years ago
(In reply to comment #32)
> Gary,
> Is it OK for you now?

It's been working fine for awhile. I have a high end machine so it still could affect folks with lower performance machines.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101212 Firefox/4.0b8pre - Build ID: 20101212030333
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110302 Firefox/4.0b13pre ID:20110302030357
http://hg.mozilla.org/mozilla-central/rev/919f15d71153
about:support Info: http://pastebin.com/PWnFMjtA

above Build using D2D+D3D10 @1000 Fish: 38 FPS
MSIE 9 RC1: 47 FPS

I see no Difference with flipping javascript.options.tracejit.content.
Blocks: 918620
You need to log in before you can comment on or make changes to this bug.