Closed Bug 586317 Opened 9 years ago Closed 9 years ago

Add Search Engine option is always offered even after adding

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: tchung, Assigned: vingtetun)

References

Details

Attachments

(2 files)

The Add Search Engine option continues to be present even after having added the search engine to fennec.

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:2.0b4pre) Gecko/20100810 Namoroka/4.04pre Fennec/2.0a1pre


Repro:
1) install N900, Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:2.0b4pre) Gecko/20100810 Namoroka/4.04pre Fennec/2.0a1pre
2) visit a site that has a search engine present (eg. yelp.com)
3) click Larry icon, and select "Add Search Engine"
4) Notice the option disappears from the list, and when you check awesomescreen, the search engine has been applied
5) Now go back to the site, and click Larry again.  Verify the option to Add Search Engine for that site appears

Expected:
- After adding the search engine once, it shouldnt be offered anymore.
flagging for 2.0 triage
tracking-fennec: --- → ?
Assignee: nobody → 21
tracking-fennec: ? → 2.0b2+
Attached patch PatchSplinter Review
The patch filters the already added search engines and allow to add the next one if there is many.
Attachment #466608 - Flags: review?(mark.finkle)
Attachment #466608 - Flags: review?(mark.finkle) → review+
Blocks: 586883
http://hg.mozilla.org/mobile-browser/rev/4352b9348dea
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on builds:
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b4pre) Gecko/20100818 Namoroka/4.0b4pre Fennec/2.0a1pre

and

Mozilla/5.0 (Android; U; Linux armv71; en-US; rv:2.0b4pre) Gecko/20100818 Namoroka/4.0b4pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
Flags: in-litmus+
this is reproducible for the amo search engine with the build:
Build Identifier: Mozilla /5.0 (Maemo; Linux armv7l; rv:2.0b6pre)Gecko/20100906 Firefox/4.0b6pre Fennec /2.0b1pre
Reopen the bug.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Attached patch PatchSplinter Review
This is a regression introduce by myself in changeset http://hg.mozilla.org/mobile-browser/diff/f0f2f91b0ed8/chrome/content/browser.js

The patch also fix an error when you open the site menu because we try to access contentDocument which throw an error now.
Attachment #476212 - Flags: review?(mark.finkle)
Attachment #476212 - Flags: review?(mark.finkle) → review+
Whiteboard: [fennec-checkin-postb1]
pushed:
http://hg.mozilla.org/mobile-browser/rev/11e4da3cd530
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Whiteboard: [fennec-checkin-postb1]
verified FIXED on builds:

Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100930 Namoroka/4.0b7pre Fennec/4.0b1pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100930 Namoroka/4.0b7pre Fennec/4.0b1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.