302 redirects do not trigger visited link highlighting

VERIFIED DUPLICATE of bug 41973

Status

()

P3
normal
VERIFIED DUPLICATE of bug 41973
18 years ago
18 years ago

People

(Reporter: stephe, Assigned: gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
If you click on a link that triggers an HTTP 302 redirect, the link does not get
the visited highlighting.

To reproduce:
Load the About page (Help/About Mozilla) and click on the "Netscape Public
License" link (http://www.mozilla.org/NPL).  This link results in a 302 redirect
to http://www.mozilla.org/MPL.  Now go back to the About page.  The "Mozilla
Public License" link get the visited highlighting, but the "Netscape Public
License" link does not.

I would expect the "Netscape Public License" link to get the visited
highlighting, and this is what both NN4 and IE5 do.

Tested with Mozilla 103104 trunk build on NT4.

Comment 1

18 years ago
Also works for me on build id 2000110304, i can reproduce it exactly.
Could anyone confirm that this is not the correct behaviour?

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 41973 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.