TM: jsapi tests still emits code into the default compartment

RESOLVED DUPLICATE of bug 589216

Status

()

RESOLVED DUPLICATE of bug 589216
8 years ago
8 years ago

People

(Reporter: gwagner, Assigned: gal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
testContexts_bug561444

Assertion failure: (cx->runtime->defaultCompartmentIsLocked == true), at ../jsgcinlines.h:67

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x0000000000000000
[Switching to process 22183]
0x000000010017f5b9 in JS_Assert (s=0x100214c40 "(cx->runtime->defaultCompartmentIsLocked == true)", file=0x10022a6a0 "../jsgcinlines.h", ln=67) at ../jsutil.cpp:80
80	    *((int *) NULL) = 0;  /* To continue from here in GDB: "return" then "continue". */
(gdb) bt
#0  0x000000010017f5b9 in JS_Assert (s=0x100214c40 "(cx->runtime->defaultCompartmentIsLocked == true)", file=0x10022a6a0 "../jsgcinlines.h", ln=67) at ../jsutil.cpp:80
#1  0x000000010016bdbc in NewFinalizableGCThing<JSShortString> (cx=0x101006120, thingKind=3) at jsgcinlines.h:66
#2  0x000000010016bee9 in js_NewGCShortString (cx=0x101006120, comp=0x100617bb0) at jsgcinlines.h:104
#3  0x00000001001669c6 in js_ConcatStrings (cx=0x101006120, left=0x1002beef0, right=0x1002bf390) at ../jsstr.cpp:284
#4  0x000000010010fa14 in FoldXMLConstants (cx=0x101006120, pn=0x101829a20, tc=0x101480760) at ../jsparse.cpp:8598
#5  0x00000001001182fc in js_FoldConstants (cx=0x101006120, pn=0x101829a20, tc=0x101480760, inCond=false) at ../jsparse.cpp:9136
#6  0x0000000100116d57 in js_FoldConstants (cx=0x101006120, pn=0x101829ab0, tc=0x101480760, inCond=false) at ../jsparse.cpp:8740
#7  0x00000001001171be in js_FoldConstants (cx=0x101006120, pn=0x101829c18, tc=0x101480760, inCond=false) at ../jsparse.cpp:8815
#8  0x000000010011700e in js_FoldConstants (cx=0x101006120, pn=0x101829c60, tc=0x101480760, inCond=false) at ../jsparse.cpp:8779
#9  0x000000010011700e in js_FoldConstants (cx=0x101006120, pn=0x101829d80, tc=0x101480760, inCond=false) at ../jsparse.cpp:8779
#10 0x00000001001170f9 in js_FoldConstants (cx=0x101006120, pn=0x101829dc8, tc=0x101480760, inCond=false) at ../jsparse.cpp:8800
#11 0x0000000100125c3f in js::Compiler::compileScript (cx=0x101006120, scopeChain=0x101303048, callerFrame=0x0, principals=0x0, tcflags=8192, chars=0x101002620, length=22, file=0x0, filename=0x100212540 "../../jsapi-tests/testContexts.cpp", lineno=71, source=0x0, staticLevel=0) at ../jsparse.cpp:846
#12 0x0000000100015d3b in JS_EvaluateUCScriptForPrincipals (cx=0x101006120, obj=0x101303048, principals=0x0, chars=0x101002620, length=22, filename=0x100212540 "../../jsapi-tests/testContexts.cpp", lineno=71, rval=0x101480ec8) at ../jsapi.cpp:4788
#13 0x0000000100015e4c in JS_EvaluateScriptForPrincipals (cx=0x101006120, obj=0x101303048, principals=0x0, bytes=0x1002125c9 "<a><b/></a>.b.@c = '';", nbytes=22, filename=0x100212540 "../../jsapi-tests/testContexts.cpp", lineno=71, rval=0x101480ec8) at ../jsapi.cpp:4817
#14 0x0000000100015ec1 in JS_EvaluateScript (cx=0x101006120, obj=0x101303048, bytes=0x1002125c9 "<a><b/></a>.b.@c = '';", nbytes=22, filename=0x100212540 "../../jsapi-tests/testContexts.cpp", lineno=71, rval=0x101480ec8) at ../jsapi.cpp:4826
#15 0x0000000100006987 in cls_testContexts_bug561444::threadMain (arg=0x7fff5fbff7a0) at ../../jsapi-tests/testContexts.cpp:71
#16 0x00000001004eabee in PR_JoinThread ()
#17 0x00007fff839bb456 in _pthread_start ()
#18 0x00007fff839bb309 in thread_start ()
(Reporter)

Updated

8 years ago
Blocks: 558861
(Reporter)

Updated

8 years ago
Depends on: 586450
It's just a busted jsapi-test.
(Assignee)

Updated

8 years ago
Assignee: general → gal
No longer depends on: 586450
Summary: TM: Defaultcompartment bugs for the shell. → TM: jsapi tests still emits code into the default compartment
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589216
You need to log in before you can comment on or make changes to this bug.