Closed Bug 586547 Opened 12 years ago Closed 11 years ago

TM: Different values with testcase containing for...each, for...in, Boolean()

Categories

(Core :: JavaScript Engine, defect)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 587964

People

(Reporter: gkw, Assigned: dvander)

References

Details

(Keywords: testcase)

try {
    for each(ex in [Boolean()])
    function gs() {}
    x = []
    var b = [];
    for ([, b] in this) {
        print(b)
    }
    var e
} catch (e) {}

Tested on JM changeset f7cf2b7b7961, this doesn't seem to occur on TM.

Without any parameters, this returns (the same result as the TM branch shells):

undefined
undefined
x
s
undefined

With -j on JM, this returns a different result:

undefined
undefined
x
s

(Note the last missing "undefined")
I think this is a dup of bug 585260.
Assignee: general → dvander
Status: NEW → ASSIGNED
This reproduces on tm-tip with HOTLOOP = 3. Bisecting.
Summary: JM: Different values with testcase containing for...each, for...in, Boolean() → TM: Different values with testcase containing for...each, for...in, Boolean()
changeset:   48671:fd0411f5ce7f
user:        Andreas Gal <gal@mozilla.com>
date:        Thu Aug 05 22:54:34 2010 -0700
summary:     Optimize string[idx] on trace (584499, r=lw).
Maybe a dup of bug 587964
Good call.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587964
You need to log in before you can comment on or make changes to this bug.