nsSyncHelper uses a native event queue

VERIFIED FIXED in mozilla0.9

Status

()

Core
Networking: HTTP
P3
normal
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: dmose, Assigned: Darin Fisher)

Tracking

Trunk
mozilla0.9
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
According to dougt, this should be a monitored event queue.
(Assignee)

Comment 1

17 years ago
I'm just wondering... do we have an instance where this is getting us into
trouble?
Assignee: gagan → darin
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 2

17 years ago
It would be a hard thing to identify user level problems caused by this bug in http.

gagan, this is another place where messages could become out of sync.
(Assignee)

Comment 3

17 years ago
Understood... can you point me to an example that uses monitored event queues.
I'd like understand what exactly needs to change.
(Assignee)

Comment 4

17 years ago
Doug, is this just as simple as replacing CreateThreadEventQueue() with
CreateMonitoredThreadEventQueue()?
--darin

Comment 5

17 years ago
yes.  and lots of testing.  :-)
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future
(Reporter)

Comment 6

17 years ago
This seems potentially fairly dangerous; nominating for mozilla0.9.
Keywords: mozilla0.9
(Assignee)

Comment 7

17 years ago
In the grand scheme of things nsSyncHelper is going away in favor of a true
synchronous HTTP implementation.  My feeling on this bug is therefore to just
leave it for now, and wait for the better solution.  However, I'd like to know
if people feel that this should still be "fixed" at least for the time being.
AFAIK, synchronous HTTP is heavily used (at least not in mozilla).
(Assignee)

Comment 8

17 years ago
I meant to say that synchronous HTTP is _NOT_ heavily used in mozilla.
Component: Networking → Networking: HTTP
(Assignee)

Updated

17 years ago
Blocks: 61697
(Assignee)

Comment 9

17 years ago
ok.. it looks like the new sync http impl is not going to happen for a while, so
i'm going to go ahead and patch up the existing impl.

adding dependency on bug 59434.
Depends on: 59434
(Assignee)

Comment 10

17 years ago
nominating for moz 0.9
Target Milestone: Future → mozilla0.9
(Assignee)

Comment 11

17 years ago
Created attachment 25704 [details] [diff] [review]
Makes HTTP use a monitored event queue inside OpenInputStream

Comment 12

17 years ago
looks good.  I am shocked that this didn't cause more problems.  r=doug.

please ci after I land my branch/.
(Assignee)

Comment 13

17 years ago
only causes problems if there are other threads touching HTTP.

Comment 14

17 years ago
sr=mscott
(Assignee)

Comment 15

17 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.