please add support for mkv and flac to be used in video and audio elements

VERIFIED DUPLICATE of bug 1195723

Status

()

enhancement
VERIFIED DUPLICATE of bug 1195723
9 years ago
3 years ago

People

(Reporter: linuxed7, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.5) Gecko/2008121716 Firefox/3.0.5 Flock/2.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.9pre) Gecko/20100808 Ubuntu/10.04 (lucid) Namoroka/3.6.9pre

It would be a great addition to Firefox if you could add support for the mkv container and the flac codec to be used in video and audio elements.  They're both open formats so there shouldn't be any licensing issues.

<!-- mkv/vp8/vorbis -->
<video src="example.mkv"></video>
<audio src="example.flac"></audio>

Reproducible: Always
You should probably do these as separate bugs. Raise one for Flac support (similar to how there's one for Speex in bug 476752) and change this one to mkv support for example. mkv being a container you'd need to be more explicit about what codecs in the container you'd want to support. Given we suport webm with VP8/Vorbis I don't see supporting mkv to be that likely since anyone doing VP8/Vorbis is likely to use WebM.
Marking WONTFIX, since we're not currently planning to implement this. We can reopen if our plans change.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
do we want mkv/flac support for B2G project ?
Duplicate of this bug: 733779
Duplicate of this bug: 926111
Maybe can this be implemented the same way as the MP3/H264 decoders, using the system ones when available?
https://bugzilla.mozilla.org/show_bug.cgi?id=1039639 appears to only apply to FirefoxOS. Does a separate bug/feature-request entry need to be opened for Firefox (the browser)?

(FLAC support didn't seem useful to me for a browser previously, but as "web app" emphasis increases and "local" web-apps for media playback get developed, support for a lossless format seems appropriate to me. Parity between Firefox and FirefoxOS regarding media support seems like a reasonable desire as well...)
FLAC support directly in the browser is useful if you have a web application for browsing a media library. Currently, FLAC cannot be auditioned using a widget such as jPlayer (http://jplayer.org/) even though FLAC is a better format than WAV (not only is the download time reduced with FLAC, but the metadata support makes FLAC much more suitable for web use than WAV).
Do any other desktop browsers support FLAC?
As far as I know, none of them support it natively yet, but it can be made to work using https://github.com/audiocogs/flac.js
I have opened bug 1195723 for FLAC.

Support in Chrome may be coming soon https://code.google.com/p/chromium/issues/detail?id=93887
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1195723
You need to log in before you can comment on or make changes to this bug.