JM: "Assertion failure: IsSaneThisObject(argv[-1].toObject())," (again)

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: jbramley, Assigned: jbramley)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 465168 [details] [diff] [review]
Fix for the non-PIC case.

I get the same failure as in bug 585341 and bug 578041, but with PICs disabled. The fix is the same, I think, though I'm not familiar with the code so there may be something that I've missed.
Attachment #465168 - Flags: review?(cdleary)
Yeah, this is https://bugzilla.mozilla.org/show_bug.cgi?id=586188. And with exactly the same patch!

I'll close my version since this one is better-integrated.

Updated

8 years ago
Duplicate of this bug: 586188
Comment on attachment 465168 [details] [diff] [review]
Fix for the non-PIC case.

Looks exactly the way that I would write it. ;-)

If two people produce exactly the same patch, that should probably count as a second review.

Do you need a checkin Jacob? I forget if you've got commit access yet.
Attachment #465168 - Flags: review?(cdleary) → review+
Figured Jacob's in a different timezone so I just pushed away.

http://hg.mozilla.org/projects/jaegermonkey/rev/9230ae392642
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.