Input of characters (@,€) on with non-english keymap not possible when using iFrame and wmode other than default

RESOLVED DUPLICATE of bug 347185

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 347185
7 years ago
6 years ago

People

(Reporter: Christoph Petersen, Unassigned)

Tracking

({flashplayer, inputmethod, pp})

3.6 Branch
x86
Windows XP
flashplayer, inputmethod, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.126 Safari/533.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

Were developing an application which makes heavy use of different Flash applications mashed together with HTML. We have to use wmode=transparent as we need to display other components ontop of our Flash based components.

When the Flash applications are contained within an iFrame the Flash application does not receive the input from the browser anymore.

Reproducible: Always

Steps to Reproduce:
1. Change keyboard mapping to de_DE
2. Open http://www.xgrr.de/ff-flash-problem/
3. Try to enter @ or € by pressing AltGr (right alt+q or right alt+e) in Flash app on the right
Actual Results:  
Nothing will be entered into the text field.

Expected Results:  
@ and € should be entered in the text field.
Do you mean bug 347185 ?
note: Please always include the used flash version in a bug report.
(Reporter)

Comment 2

7 years ago
No that defect describes the problems without the additional <iframe> element around the Flash application. Without the iframe this problem is not reproducible in our environment.

I'm using Flash 10,1,82,76. And the problem occurs only on Windows (up to Windows 7).
(Reporter)

Updated

7 years ago
Keywords: flashplayer, inputmethod, pp
OS: Windows 7 → Windows XP
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 3

6 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 5? Does the issue occur with the latest nightly? http://nightly.mozilla.org/
(Reporter)

Comment 4

6 years ago
With the nightly build the problem is fixed. Is there any indication when this is pushed into the stable release?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347185
You need to log in before you can comment on or make changes to this bug.