Middleclick paste fails with silent clipboard error

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
major
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
STEPS TO REPRODUCE
   Set "middlemouse.paste" to true (or use unix)
   Load Mozilla
   Right click on a link
   Middle click on the document instance

EXPECTED RESULTS
   You navigate to the page whose URI you copied to the clipboard

ACTUAL RESULTS
   Component returned failure code: 0x80004005, nsIClipboard.getData in 
   JS frame :: chrome://navigator/content/navigator.js :: readFromClipboard ::
   line 1542, data: no.

The exception is caught and silently dropped, and we fail to paste the link.

This was tested on Windows 2000 using a Netscape commercial branch build from 
Oct 30 2000. From browsing LXR it seems to me that on the trunk the code will 
only get called if you middle-click on a link, because of a regression that I 
think was introduced by Blake recently. I don't know if there is a bug on that.
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0
Is this a duplicate of bug 58333?
i think so...

*** This bug has been marked as a duplicate of 58333 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
vrfy dup
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
Perhaps nobody really uses middle-click pasting on Windows... This bug is NOT
fixed (on Windows), and I don't believe it's a dupe of bug 58333. See 111337
comment 19 - there it surfaced again. I get the exact error message that is
mentioned in this bug's description.
Status: VERIFIED → REOPENED
Keywords: mozilla1.0
Resolution: DUPLICATE → ---

Updated

15 years ago
Blocks: 111337

Comment 5

15 years ago
Changing to the component that I believe is appropriate for this, based on the
component descriptions, and reassigning.
Assignee: ben → jaggernaut
Status: REOPENED → NEW
Component: XP Apps: GUI Features → XP Toolkit/Widgets
QA Contact: sairuh → jrgm

Comment 6

12 years ago
(In reply to comment #0)
> STEPS TO REPRODUCE
>    Set "middlemouse.paste" to true (or use unix)
>    Load Mozilla
>    Right click on a link
>    Middle click on the document instance

does this mean middle click in the LINK?

Comment 7

11 years ago
WFM on trunk (SM & FF), windows XP - can't find what fixed it.  
Status: NEW → RESOLVED
Last Resolved: 17 years ago11 years ago
QA Contact: jrgmorrison → xptoolkit.xul
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.