Closed Bug 587249 Opened 12 years ago Closed 11 years ago

Major Australian News Sites Formatted and Messed Up In Firefox 4

Categories

(Tech Evangelism Graveyard :: English Other, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: scott, Unassigned)

References

(Blocks 1 open bug, )

Details

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3) Gecko/20100805 Firefox/4.0b3
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3) Gecko/20100805 Firefox/4.0b3

Display issues with adelaidenow.com.au theaustralian.com.au and other news limited sites.





Reproducible: Always

Steps to Reproduce:
1.Open adelaidenow.com.au and scroll to the bottom.
2.Open theaustrallian.com.au and scroll to the bottom.

Actual Results:  
As above

Expected Results:  
Website is unusable at the bottom

Displayed the page properly
Build Worked : 
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091201 Minefield/3.7a1pre

Build Broken : 
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091202 Minefield/3.7a1pre

Pushlog : 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f3c1c9fb57
&tochange=a5e1b195ecf7
Status: UNCONFIRMED → NEW
Ever confirmed: true
Thanks for the bug report!

The problem is in <http://resources1.news.com.au/cs/js/tanto-min.js>. It uses "use strict"; but relies on that not working:

> Error: assignment to undeclared variable _global_
> Source File: http://resources1.news.com.au/cs/js/tanto-min.js
> Line: 1
Assignee: nobody → english-other
Blocks: es5strict
Component: General → English Other
OS: Windows 7 → All
Product: Firefox → Tech Evangelism
QA Contact: general → english-other
Hardware: x86 → All
Great! Glad it's not just me :) Look forward to it being fixed so I can use Firefox 4 again. Cheers
To be clear, Scott, you (or someone else) need to contact the site, explain the problem (feel free to point them to this bug), and get them to fix their site. There is nothing the Firefox or Gecko developers can do to fix this in Firefox (or any other browser).

cl
Why does it work fine in Firefox 3 then?
(In reply to comment #5)
> Why does it work fine in Firefox 3 then?

It appears from comment 2 that they were relying on a bug in Firefox 3 to continue to exist indefinitely. Needless to say, re-introducing that bug is not going to happen.

cl
I should be clearer: we have introduced a new JavaScript feature, ES5 strict mode, [1] which requires opt-in from the script author in such a way that older browsers just ignore it. Strict mode is intended to make JavaScript more predictable and to catch JavaScript errors earlier, by raising exceptions.

In this case, the script assigns a value to an implicit global variable [2], which works in normal JavaScript but is forbidden in strict mode. There are two possible solutions here:

1. Remove the '"use strict";' statement at the start of
   <http://resources1.news.com.au/cs/js/tanto-min.js>, to avoid opting into
   strict mode.
2. Audit the script for strict mode problems, in particular change
     'if(typeof _global_==="undefined"){_global_={...'
   to
     'if(typeof _global_==="undefined"){var _global_={...'
   There probably are other problems, though.

Option 1. is probably the easiest for them.

[1] <http://ejohn.org/blog/ecmascript-5-strict-mode-json-and-more/> is a good
    introduction.
[2] Mentioned, for example, in <http://javascript.crockford.com/style2.html>
Is anyone evangelizing the site?

/be
I have found this bug to be fixed. All News.com.au sites I visit now work fine in Firefox 4 beta 8. I would recommend that it be closed now.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.