Restored window is not visible if secondary display is not connected

VERIFIED DUPLICATE of bug 583316

Status

()

Firefox
Session Restore
VERIFIED DUPLICATE of bug 583316
7 years ago
7 years ago

People

(Reporter: Janet Swisher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3) Gecko/20100805 Firefox/4.0b3
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3) Gecko/20100805 Firefox/4.0b3

When the display that a window was on is not available when the session is restored, the window is not visible.

Reproducible: Always

Steps to Reproduce:
1. On a laptop with an external monitor, create a Firefox window with multiple tabs.
2. Quit Firefox, and choose "Save and Quit".
3. Shut down the system.
4. Disconnect the external monitor.
5. Restart the system.
6. Start Firefox. 
Actual Results:  
The Firefox menubar appears, and the restored window is listed on the Window menu, but the window is not displayed, and is not visible in Exposé. 

If you now quit Firefox, the missing window suddenly appears under the "Quit Firefox?" dialog, which is messed up as shown in the attached screenshot.

Expected Results:  
In previous versions of Firefox, the edge of the window would be visible on the laptop display.

I have also experienced, but have not been able to reproduce, situations where the window does not reappear when quitting. In these situations, if you choose "Save and Quit" and then restart FF, you get the same problem (window not visible); if you choose "Quit" and then restart FF, the fresh window is a only a few pixels wide (and a few hundred tall).

I'll add a comment if I find a repro path for that.
(Reporter)

Comment 1

7 years ago
Created attachment 465919 [details]
The "Quit Firefox?" dialog that appears when the main window is not visible

Comment 2

7 years ago
Dupe of bug 583316, can someone with canedit mark as such - thanks!

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583316
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.