[d2d] on darkroom demo, image doesn't display unless it's zoomed

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: shaver, Assigned: bas.schouten)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

()

Attachments

(1 attachment)

I don't get the image shown unless I zoom it (click in the middle of the white area somewhere).  Resetting zoom via the button makes it disappear again.
Ahem, this was only when I had D2D enabled.  Sorry for not mentioning that.
Component: Widget: Win32 → Graphics
QA Contact: win32 → thebes
Summary: on darkroom demo, image doesn't display unless it's zoomed → [d2d] on darkroom demo, image doesn't display unless it's zoomed

Comment 2

9 years ago
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/022b9e8492a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre ID:20100810172755
Fails:
http://hg.mozilla.org/mozilla-central/rev/72ec4df3de76
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre ID:20100810221002
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=022b9e8492a1&tochange=72ec4df3de76
Assignee

Comment 3

9 years ago
(In reply to comment #2)
> Regression window:
> Works:
> http://hg.mozilla.org/mozilla-central/rev/022b9e8492a1
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810
> Minefield/4.0b4pre ID:20100810172755
> Fails:
> http://hg.mozilla.org/mozilla-central/rev/72ec4df3de76
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810
> Minefield/4.0b4pre ID:20100810221002
> Pushlog:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=022b9e8492a1&tochange=72ec4df3de76

Very good to have this regression window! It will make it much easier for us to track down. Thanks.
Note: the demo does canvas-to-canvas drawing, which sounds like might have been broken with the changes.  Can probably create an isolated testcase just by creating two canvases, and using drawImage to draw one into the other.
Assignee

Comment 5

9 years ago
This causes fallback to use, because the canvas isn't drawn at a pixel aligned position due to the transform, and is using OPERATOR_SOURCE. We could use OVER for these cases on D2D since we clear the surface anyway for source. Additionally we could add optimized D3D code for easily mapped quad draw calls like this.

In any case to fix this for now we should fix fallback so it is correct, it was not using the correct destination image surface content.
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
Attachment #466207 - Flags: review?(jmuizelaar)
Attachment #466207 - Flags: review?(jmuizelaar) → review+
Also, please create a reftest for this.
blocking2.0: --- → betaN+
Assignee

Comment 7

9 years ago
http://hg.mozilla.org/mozilla-central/rev/bffe7baa4e00

Remaining open since we want to add a reftest.
Assignee

Comment 8

9 years ago
This requires only a reftest. Although this is important I do not believe that part of this bug blocks any release.
Assignee

Updated

9 years ago
blocking2.0: betaN+ → ?
Just file a followup bug for the reftest.
Status: ASSIGNED → RESOLVED
blocking2.0: ? → betaN+
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.