[OS/2] let YARR build on OS/2

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: wuno, Assigned: wuno)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(2 attachments)

(Assignee)

Description

8 years ago
User-Agent:       Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0b4pre) Gecko/20100814 Minefield/4.0b4pre
Build Identifier: 

YARR was ported from webkit to tracemonkey in bug564953. Since OS/2 is not a webkit supported platform - building mozjs.lib breaks during linking due to unresolved symbols. We need an OS/2 specific ExecutableAllocator file as well as some changes to the Platform header.

Reproducible: Always
(Assignee)

Updated

8 years ago
Blocks: 564953
(Assignee)

Comment 1

8 years ago
Created attachment 466038 [details] [diff] [review]
v1 first try

the patch adds ExecutableAllocatorOS2.cpp and change Platform.h to recognize OS/2. I've mostly tried to convert the lines we ported to dlmalloc in libffi. At least the browser builds and runs...
Assignee: general → wuno
Status: NEW → ASSIGNED
Attachment #466038 - Flags: review?(dragtext)

Comment 2

8 years ago
(In reply to comment #0)

> YARR was ported from webkit to tracemonkey in bug564953. Since OS/2 is not a
> webkit supported platform - building mozjs.lib breaks during linking due to
> unresolved symbols. We need an OS/2 specific ExecutableAllocator file as well
> as some changes to the Platform header.

Wonder if it would be worth looking at the OS/2 port of QT4 at netlabs and their webkit. I have a browser here, Arora 0.10.2, which says it's WebKit version: 532.4.
http://www.ecomstation.it/ecsoft2/prog.php?progid=1608&name=Arora&sys=os2+ecomstation
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> 
> Wonder if it would be worth looking at the OS/2 port of QT4 at netlabs and
> their webkit. I have a browser here, Arora 0.10.2, which says it's WebKit
> version: 532.4.
Looking at the QTwebkit port, the patch appears to be quite reasonable.
One may add to the function ExecutablePool::Allocation ExecutablePool::systemAlloc(size_t n)

        if (allocation != NO_ERROR) 
 	CRASH();
as Dmik did in the respective qtwebkit file. BTW, the implementation of the os2 changes happens in the main allocator file, and just a couple of days ago the platform allocator files were retracted from webkit trunk and all the platform specific allocation functions were munged into the main allocator file.

Updated

8 years ago
Attachment #466038 - Flags: review?(dragtext) → review+

Comment 4

8 years ago
Wonder if this should also be reviewed by one of the JavaScript people?
(Assignee)

Comment 5

8 years ago
Comment on attachment 466038 [details] [diff] [review]
v1 first try

Andreas, the OS/2 bits are in principle ok. Anything else you want to mention on this patch, as it touches a few js files as well? I guess we don't need an upstreamable version of this patch, since it's only a small part of webkit that was ported to the needs of mozilla (there's no OS/2 port of webkit available).
Attachment #466038 - Flags: review?(gal)
(Assignee)

Comment 6

8 years ago
Created attachment 477248 [details] [diff] [review]
v1 qrefreshed for bitrot
Attachment #477248 - Flags: review?(gal)
(Assignee)

Updated

8 years ago
Attachment #466038 - Flags: review?(gal)

Comment 7

8 years ago
Comment on attachment 477248 [details] [diff] [review]
v1 qrefreshed for bitrot

Thanks!
Attachment #477248 - Flags: review?(gal) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Whiteboard: TM
(Assignee)

Updated

8 years ago
Whiteboard: TM → TraceMonkey
(Assignee)

Comment 8

8 years ago
Comment on attachment 477248 [details] [diff] [review]
v1 qrefreshed for bitrot

pretty low risk for tier_1 platforms all ifdef sections
Attachment #477248 - Flags: approval2.0?
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Whiteboard: TraceMonkey
(Assignee)

Comment 9

8 years ago
(In reply to comment #7)
> Comment on attachment 477248 [details] [diff] [review]
> v1 qrefreshed for bitrot
> 
> Thanks!

gal, just for clarification as I was told so in another bug related to tracemonkey. Do tracemonkey patches have to be approved for mozilla-2.0? Asking because this waits for approval now for several weeks. Before, it was sitting with the checkin-needed flag ("tracemonkey" in the whiteboard) as well for several weeks (maybe noone was really sure, if the patch needs approval).
Thanks
Walter: no one was cc'ed who might actually check the patch in.

Porting fixes can go in any time if they affect only the non-tier-1 platform.

/be
Keywords: checkin-needed
(Assignee)

Updated

8 years ago
Whiteboard: Checkin to TraceMonkey repo, NPOTB approval not required c#10
Version: unspecified → Trunk
http://hg.mozilla.org/tracemonkey/rev/8003e273cd7e
Keywords: checkin-needed
Whiteboard: Checkin to TraceMonkey repo, NPOTB approval not required c#10 → fixed-in-tracemonkey
Attachment #477248 - Flags: approval2.0?
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.