Last Comment Bug 587398 - Alt+Home Keyboard Shortcut Broken; Key Event Modifier navigator.xul
: Alt+Home Keyboard Shortcut Broken; Key Event Modifier navigator.xul
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- minor with 1 vote (vote)
: seamonkey2.1b1
Assigned To: Bruno 'Aqualon' Escherl
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-14 21:21 PDT by therube
Modified: 2010-09-06 14:42 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
change caller (Neil's proposal) [Checkin: Comment 8] (3.90 KB, patch)
2010-08-25 06:50 PDT, Bruno 'Aqualon' Escherl
iann_bugzilla: review+
Details | Diff | Splinter Review
change callee (alternativ approach) (845 bytes, patch)
2010-08-25 06:53 PDT, Bruno 'Aqualon' Escherl
iann_bugzilla: feedback-
Details | Diff | Splinter Review

Description therube 2010-08-14 21:21:48 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b4pre) Gecko/20100814 SeaMonkey/2.1a3pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b4pre) Gecko/20100814 SeaMonkey/2.1a3pre

 
Alt+Home keyboard shortcut should load Home Page.
It no longer does.
 

Reproducible: Always

Steps to Reproduce:
 
1. Open browser
2. Hit Alt+Home
 
Actual Results:  
 
None.
 

Expected Results:  
 
Home Page should load.
 

 
2010-08-08 works
2010-08-09 broken

(hope I've got this right):
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2010-08-09&enddate=2010-08-10

Possibly:

Warning: Key event not available on some keyboard layouts: key="d" modifiers="accel,alt"
Source File: chrome://navigator/content/navigator.xul
Line: 0

Which then points to these two bugs:

Bug 427520 - List of warnings for |Bug 311756 – Some "Warning: Key event not available on ...", after 2008-04-07 checkin

Bug 311756 - Some "Warning: Key event not available on ..."
Comment 1 erpman1 2010-08-16 10:19:06 PDT
you're not alone, therube.  tested this bug on my WinXP SP3 computer with SM 2.1a3pre 20100811 nightly build and Alt+Home key combo does not load the Seamonkey home page.  I guess this bug happens on all supported versions of Windows with the 8/9/2010 nightly build or higher installed.
Comment 2 Bruno 'Aqualon' Escherl 2010-08-19 02:36:51 PDT
I made some alert-debugging and found out that target in http://mxr.mozilla.org/comm-central/source/suite/browser/navigator.js#850 is null, so we don't enter any of the switch cases.

Perhaps related to bug 588070?
Comment 3 neil@parkwaycc.co.uk 2010-08-19 13:36:03 PDT
It's unanticipated fallout from the Places bookmarks landing - the old BrowserHome method ignored the Alt key, but the new one does not.

The quick fix is to make key_home use oncommand="BrowserHome();" instead.
Comment 4 Bruno 'Aqualon' Escherl 2010-08-25 06:50:49 PDT
Created attachment 469037 [details] [diff] [review]
change caller (Neil's proposal) [Checkin: Comment 8]

This patch implements the quick fix Neil mentioned in the previous comment.
Comment 5 Bruno 'Aqualon' Escherl 2010-08-25 06:53:32 PDT
Created attachment 469038 [details] [diff] [review]
change callee (alternativ approach)

This is an alternative approach, where we set target to current if it's null and alt-key is pressed. Cannot say if this is a good idea, because I didn't understand from the usage of BrowserHome() why we need the aEvent at all.
Comment 6 Ian Neal (Away until 7th Aug) 2010-09-04 04:59:04 PDT
Comment on attachment 469037 [details] [diff] [review]
change caller (Neil's proposal) [Checkin: Comment 8]

As there will be only one consumer for Browser:Home left, is it worth removing it completely?
Comment 7 Ian Neal (Away until 7th Aug) 2010-09-04 05:06:02 PDT
Comment on attachment 469038 [details] [diff] [review]
change callee (alternativ approach)

I prefer the other approach.
Comment 8 Ian Neal (Away until 7th Aug) 2010-09-06 14:38:34 PDT
Comment on attachment 469037 [details] [diff] [review]
change caller (Neil's proposal) [Checkin: Comment 8]

http://hg.mozilla.org/comm-central/rev/ba68b04c0ab1
Comment 9 neil@parkwaycc.co.uk 2010-09-06 14:41:50 PDT
(In reply to comment #5)
>I didn't understand from the usage of BrowserHome() why we need the aEvent at all.
Holding Ctrl down while clicking the Home button, or middle-clicking the Home button, will cause the home page to open in a new tab or window, assuming you have tabbed browsing preferences configured appropriately.

Note You need to log in before you can comment on or make changes to this bug.