click Java script bookmark and jump to new url, but the location bar keeps the old one

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Jemini, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3) Gecko/20100805 Firefox/4.0b3
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3) Gecko/20100805 Firefox/4.0b3

some useful java scripts bookmark help us to translate current page such as google translate, after click the bookmark the page will jump to an new url like this: "http://tranlste.google.com/....",  you will find out the change in the location bar at the same time while loading translate result, in 3.0 serial versions but the 4.0b3 does NOT.

Reproducible: Always

Steps to Reproduce:
1.open a webpage
2.click google transate bookmark
3.the url does not change in location bar
Actual Results:  
the real url of the web document 

Expected Results:  
the translate page url

it seems that the privilege of java script is modified or changed since version 3.x because this problem doesn't happen in old versions.
(Reporter)

Comment 1

7 years ago
Created attachment 466105 [details]
the url in location bar does not match the document's url.
(Reporter)

Comment 2

7 years ago
I think this bug is only a display problem. I try to use "copy tab URL" function (by tab mix plus) and paste to an notepad, oh, here is the correct URL, wow~

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 3

4 years ago
Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20130724 Firefox/25.0

It WFM with latest Nightly 25.0a1: in comment 0 step 3, the URL does change when I click on any bookmarked page which I consider the expected result.
Marking as resolved WFM; if anyone still encounters the issue or have more information to provide, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.