Last Comment Bug 587469 - Remove image map quirk from bug 264624
: Remove image map quirk from bug 264624
Status: RESOLVED FIXED
: dev-doc-complete, html5
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla5
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
:
Mentors:
Depends on: post2.0
Blocks: 264624 581644
  Show dependency treegraph
 
Reported: 2010-08-15 09:41 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-04-21 09:31 PDT (History)
4 users (show)
khuey: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (4.07 KB, patch)
2010-08-15 10:48 PDT, :Ms2ger (⌚ UTC+1/+2)
mats: review+
Details | Diff | Splinter Review
Patch v2 (3.90 KB, patch)
2010-10-15 01:28 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review
Patch for checkin (3.85 KB, patch)
2011-03-24 11:24 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2010-08-15 09:41:57 PDT
No other browser has this particular quirk, and the testcases in bug 264624 all pass without it. (I think thanks to the HTML5 parser.)
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2010-08-15 10:48:17 PDT
Created attachment 466139 [details] [diff] [review]
Patch v1
Comment 2 Olli Pettay [:smaug] (reviewing overload) 2010-08-16 02:36:37 PDT
Comment on attachment 466139 [details] [diff] [review]
Patch v1

Since Mats fixed Bug 264624, he could review this.
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2010-08-16 09:34:41 PDT
Comment on attachment 466139 [details] [diff] [review]
Patch v1

Sure.
Comment 4 Mats Palmgren (:mats) 2010-10-15 00:38:19 PDT
Comment on attachment 466139 [details] [diff] [review]
Patch v1

The code change looks good, but the test doesn't do what it's
supposed to do.  First, you need to include the script
"/tests/SimpleTest/EventUtils.js" for synthesizeMouse,
then the test also passes without the code change because
50,50 is actually outside the image (which is the builtin
"broken URL" image).  Clicking at 2,2 should work.
r=mats with that
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2010-10-15 01:28:10 PDT
Created attachment 483413 [details] [diff] [review]
Patch v2

EventUtils.js was already included, and I fixed the src and the coords to ensure I hit the right thing.
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2011-03-24 11:24:57 PDT
Created attachment 521566 [details] [diff] [review]
Patch for checkin
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-03-26 09:09:52 PDT
http://hg.mozilla.org/mozilla-central/rev/31464345fc6e
Comment 8 :Ms2ger (⌚ UTC+1/+2) 2011-04-15 09:51:58 PDT
(FWIW, I claim the dromaeo improvement on that push <http://groups.google.com/group/mozilla.dev.tree-management/browse_thread/thread/47eec39b9eb490cf/8c652ab00d54a991>.)
Comment 9 Eric Shepherd [:sheppy] 2011-04-15 11:52:53 PDT
Am I correctly interpreting this code as we no longer skip over empty maps in favor of non-empty ones if we find a matching empty map before a non-empty one, when in quirks mode?
Comment 10 :Ms2ger (⌚ UTC+1/+2) 2011-04-16 02:38:34 PDT
You are.
Comment 11 Eric Shepherd [:sheppy] 2011-04-18 12:36:09 PDT
OK, I need to clarify further. Are we talking about empty vs. non-empty map areas or maps?
Comment 12 :Ms2ger (⌚ UTC+1/+2) 2011-04-21 03:12:58 PDT
maps, as in the test:

<map name=a></map>
<map name=a><area shape=rect coords=25,25,75,75 href=#fail></map>
<img usemap=#a src=image.png>
Comment 13 Eric Shepherd [:sheppy] 2011-04-21 09:31:41 PDT
Documentation updated:

https://developer.mozilla.org/en/HTML/Element/map

Also mentioned on Firefox 5 for developers.

Note You need to log in before you can comment on or make changes to this bug.