Last Comment Bug 587527 - Disabled button remains disabled after refresh
: Disabled button remains disabled after refresh
Status: RESOLVED DUPLICATE of bug 654072
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 3.6 Branch
: x86 Windows 7
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.nybblemouse.com/share/brok...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-15 17:52 PDT by kirgy9
Modified: 2011-11-29 13:08 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image kirgy9 2010-08-15 17:52:39 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.8) Gecko/20100722 AskTbMYC/3.8.0.12304 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.8) Gecko/20100722 AskTbMYC/3.8.0.12304 Firefox/3.6.8

A button which has been set to "disabled" via javscript, remains disabled even when the page is refreshed. This is true, even if no property to the button is changed on page-load.

However, a re-request of a webpage (retyping the URL and hitting enter) solves this problem. But why isnt the refreshed page setting the button to its original state?

Reproducible: Always

Steps to Reproduce:
1.navigate to a page
2.click a button which javascripts disables on an 'onclick' event
3.hit the browser's 'refresh' button

Actual Results:  
the button remainds disabled.

Expected Results:  
the button returns to the browser default state for a button (enabled)
Comment 1 User image Nickolay_Ponomarev 2011-11-29 13:08:19 PST

*** This bug has been marked as a duplicate of bug 654072 ***

Note You need to log in before you can comment on or make changes to this bug.