Closed Bug 587529 Opened 10 years ago Closed 2 years ago

nsIAccessibleTable's GetCellAt doesn't always return an nsIAccessibleTableCell?

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1486668

People

(Reporter: davidb, Unassigned)

References

Details

Attachments

(1 file)

Spin off from bug 583952. It appears our accessible table code can return unexpected nsAccessible types. Giving to Alexander for now, since he intimate with this code.
Summary: nsIAccessibleTable's GetCellAt doesn't always return an nsIAccessibleTableCell → nsIAccessibleTable's GetCellAt doesn't always return an nsIAccessibleTableCell?
Attached file minimal test case
To recreate the crash comment out the change in rev 092ed1804da6.
no nearest plans on this
Assignee: surkov.alexander → nobody
Fixed by bug 1486668.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1486668
You need to log in before you can comment on or make changes to this bug.