Closed Bug 587719 Opened 10 years ago Closed 10 years ago

Attempt to use application/x-moz-keywordsearch submission type for keyword search, before falling back to default submission type

Categories

(Core :: DOM: Navigation, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla2.0b4
Tracking Status
blocking2.0 --- beta4+

People

(Reporter: Gavin, Assigned: Gavin)

References

Details

Attachments

(1 file, 2 obsolete files)

This will allow search engines to specify a keyword-specific <Url>, if using the default <Url type="text/html"> isn't suitable (e.g. if you want different parameters).
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #466363 - Flags: review?(jst)
Attachment #466363 - Flags: review?(community)
Attachment #466363 - Flags: review?(community) → review?(l10n)
That patch also makes keyword.url non-localizable, since there's no longer a reason for it to be.
Comment on attachment 466363 [details] [diff] [review]
patch

Looks good to me, not that I have a good idea on the nsDefaultURIFixup.cpp part, I guess jst is up for review on that?
Attachment #466363 - Flags: review?(l10n) → review+
Attached patch updated patch (obsolete) — Splinter Review
Discussed this with Jeff, added a comment with followup accordingly.
Attachment #466363 - Attachment is obsolete: true
Attachment #466414 - Flags: review?(jmuizelaar)
Attachment #466363 - Flags: review?(jst)
Comment on attachment 466414 [details] [diff] [review]
updated patch

Looks fine, but add a comment describing why you're:

pref("keyword.URL", "");

and maybe mention the future bug near:
+const URLTYPE_MOZ_KEYWORDSEARCH = "application/x-moz-keywordsearch";
Attachment #466414 - Flags: review?(jmuizelaar) → review+
Attachment #466414 - Attachment is obsolete: true
Attachment #466416 - Flags: approval2.0?
Patch summary:
- makes change from bug 586821 apply to all locales
 - additional followup special-case bug 587730 for "ru" specifically is ready to land, coordinated with axel and ru localizer
- removes a string (minimal l10n impact)
- no code-level regression risk
blocking b4
blocking2.0: --- → beta4+
https://hg.mozilla.org/mozilla-central/rev/50334c9ac182
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b4
Attachment #466416 - Flags: approval2.0?
Blocks: 724116
You need to log in before you can comment on or make changes to this bug.