IRI/IDN gets a prefix www. and it won't resolve

RESOLVED DUPLICATE of bug 66183

Status

()

--
major
RESOLVED DUPLICATE of bug 66183
8 years ago
3 years ago

People

(Reporter: laurian, Unassigned)

Tracking

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4pre) Gecko/20100816 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4pre) Gecko/20100816 Minefield/4.0b4pre

Noticed it tweetie, but if you do it in terminal:
$ open "http://✪df.ws/g12"

Firefox will try to load http://www.✪df.ws/g12 (actually http://www.xn--df-oiy.ws/g12 ) which is not resolvable.

Reproducible: Always

Steps to Reproduce:
1. in terminal type open "http://✪df.ws/g12"
2. in firefox you have to manually remove "www." to get to the destination

Actual Results:  
Firefox can't find the server at www.%e2%9c%aadf.ws.

Expected Results:  
load http://xn--df-oiy.ws/g12
The error message could be incorrect -> bug 66183

opening http://✪df.ws/g12 via commandline is wfm with SM trunk on win32.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 66183
You need to log in before you can comment on or make changes to this bug.