Closed Bug 588099 Opened 12 years ago Closed 10 years ago

Allow users to select PGO/non-PGO windows builds for tryserver

Categories

(Release Engineering :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 691673

People

(Reporter: catlee, Unassigned)

References

Details

(Whiteboard: [tryserver])

If you don't want any perf results for your try push, then doing a non-PGO build will save quite a bit of time, and you'll get your results back faster!
And considering we don't run Talos by default...

I suspect that most people don't care about PGO, they just want to know if it compiles and passes tests. As long as PGO is still an option, for 100% fidelity to the production tree, then that should be fine.
We should also make it clear somewhere that if you want Talos you need the PGO build.
Could it be possible to make --*able-profile-guided-optimization depend on the Try Chooser Talos option by default, then let the user override that as needed?
Depends on: 603574
(In reply to comment #3)
> Could it be possible to make --*able-profile-guided-optimization depend on the
> Try Chooser Talos option by default, then let the user override that as needed?

This sounds like a good idea. If you request Talos runs on your Windows builds, you get a PGO build, otherwise you don't. Then you can provide a different switch that will let you opt into PGO builds without Talos for the rare occasion where that's wanted.
this is going to be implemented by bug 691673
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 691673
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.