Convert slow script warning dialogs to tab modal panels

RESOLVED DUPLICATE of bug 1118618

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1118618
8 years ago
3 years ago

People

(Reporter: faaborg, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Points:
13
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

Similar to bug 562258 which covers javascript dialogs, we need to make sure that the slow script warnings are tab modal panels as well.

Updated

8 years ago
Blocks: 616843

Updated

7 years ago
Blocks: 59314

Updated

7 years ago
No longer blocks: 59314

Updated

4 years ago
Blocks: 950073
Whiteboard: [feature] p=0

Updated

4 years ago
No longer blocks: 950073
Flags: firefox-backlog+
Whiteboard: [feature] p=0 → p=0

Updated

4 years ago
Whiteboard: p=0 → p=13

Updated

4 years ago
Points: --- → 13
Flags: qe-verify?
Whiteboard: p=13

Comment 1

3 years ago
Peter, how feasible is this currently? As in, if we were to spin the event loop for these dialogs... does stuff blow up? :-)
Component: General → DOM
Flags: needinfo?(peterv)
Don't think it should be more of an issue than for alert etc. Smaug, thoughts?
Flags: needinfo?(peterv) → needinfo?(bugs)

Comment 3

3 years ago
yeah, whether or not a dialog is tab modal, it spins event loop.
Flags: needinfo?(bugs)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118618
I don't believe this needs QA testing for verification. Any bugs should be caught through periodic dogfooding and beta testing.
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.