If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Support editing skiplist configuration via admin panel

RESOLVED DUPLICATE of bug 528390

Status

Socorro
General
RESOLVED DUPLICATE of bug 528390
7 years ago
6 years ago

People

(Reporter: ted, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Currently every SkipList change needs to have a bug filed, and then someone (usually Lars) has to provide the changes to the production configuration for IT to apply. It would be much simpler if Socorro supported editing the configuration via the admin panel directly. I think a simple UI would be fine, maybe something like:

Signature Generation

Skip frames matching: (irrelevantSignatureRegEx)
[ listbox ] [+] [-]

Prepend frames matching: (prefixSignatureRegEx)
[ listbox ] [+] [-]

Skip all frames before frames matching: (signatureSentinels)
[ listbox ] [+] [-]

Each listbox would contain a list of regexes. I think the underlying implementation would need to store them separately for easy editing, but it could pass them down to the processor by joining them with "|" to make a compound regex.

(There's probably some work to be done to be able to pass config information down to the processors as well, I don't know how any of that works anymore.)
(Reporter)

Updated

7 years ago
Target Milestone: --- → 2.0
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 528390
(Assignee)

Updated

6 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.