no l10n nightly updates on central

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Pike, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Right now, there are no updates offered on central, 

https://aus2.mozilla.org/update/3/Firefox/4.0b4pre/20100813041308/WINNT_x86-msvc/it/nightly/Windows_NT%206.1/default/default/update.xml?force=1 comes back empty, as do a few other urls for which I see completed l10n nightlies right now on tinderbox. Tried various locale codes on that build id, as well as on https://aus2.mozilla.org/update/3/Firefox/4.0b4pre/20100816040720/WINNT_x86-msvc/es-ES/nightly/Windows_NT%206.1/default/default/update.xml?force=1
This morning I see 4.0b5pre.it builds (from Aug 18) on ftp, but still update.xml empty, also for Mac.

This is the update URL on my Mac
https://aus2.mozilla.org/update/3/Firefox/4.0b4pre/20100816030701/Darwin_Universal-gcc3/it/nightly/Darwin%2010.4.0/default/default/update.xml?force=1

Updated

8 years ago
OS: Mac OS X → Windows XP

Comment 2

8 years ago
So this is not a windows-only bug?  Is the title of this bug incorrect?
(In reply to comment #2)
> So this is not a windows-only bug?  Is the title of this bug incorrect?

I've seen this problem only on Windows in the last weeks, but now it seems to affect also my Mac (see comment 1).
(Reporter)

Comment 4

8 years ago
I know that bhearsum had to switch off updates yesterday to not distribute the omnijars, did he switch them back on?
I have problems too, and downloading the latest nightly (es-ES) from here:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/

Gives me that it was built on 13th August, from the rev 

http://hg.mozilla.org/mozilla-central/rev/d5e211bdd793

but the date of the file in the FTP is 17th Aug at 6.18 (PST time)
Oh, I didn't noticed comment 1 about b5pre. I was talking about b4pre that is still shown on the FTP.

Checking with b5pre, about the build date.
Nevermind my latest 2 comments, getting a nice latest nightly from b5pre:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5pre) Gecko/20100818 Minefield/4.0b5pre

but still, b4pre doesn't get any updates too
(In reply to comment #4)
> I know that bhearsum had to switch off updates yesterday to not distribute the
> omnijars, did he switch them back on?

I switched them off in such a way that the next round of updates would turn them back on. Looking into this.
Assignee: nobody → bhearsum
I think this is caused by having two sets of builds in the latest-* directory. I'll remove them and try to respin the l10n nightlies.
I managed to get an update on af Mac after manually constructing a snippet.

I'm pretty certain that l10n updates are always empty between the time the en-US nightly is completed and the time the associated nightly for each locale is completed. If I'm reading this AUS code correctly, we look in the second to latest directory for updates, and no locales will have updates in that directory right after the en-US finishes:
http://mxr.mozilla.org/mozilla/source/webtools/aus/xml/inc/patch.class.php#456

We're currently waiting for something to cycle, and then we'll kick new nightlies. All green locales should receive updates in the next 4-5 hours
New en-US nightlies have been kicked. l10n ones will be triggered once their done.
Priority: -- → P1
We still haven't got this resolved. It's taking a few tries to get the repacks working again. Hoping to have it resolved for the regularly scheduled nightlies tomorrow morning.
Summary: No Windows l10n nightly updates on central → no l10n nightly updates on central
l10n builds completed successfully overnight, we need another run to get working updates though. I've kicked that off now.
These seem to be showing up now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
I'm using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre SK locale

trying to check for updates:
AUS:SVC Checker:getUpdateURL - update URL: https://aus2.mozilla.org/update/3/Firefox/4.0b5pre/20100824040950/WINNT_x86-msvc/sk/nightly/Windows_NT%206.1/default/default/update.xml?force=1
AUS:SVC Checker:checkForUpdates - sending request to: https://aus2.mozilla.org/update/3/Firefox/4.0b5pre/20100824040950/WINNT_x86-msvc/sk/nightly/Windows_NT%206.1/default/default/update.xml?force=1
AUS:SVC Checker:onLoad - request completed downloading document
AUS:SVC Checker:onLoad - number of updates available: 0
AUS:UI gCheckingPage:onCheckComplete - no update found


looking at http://tinderbox.mozilla.org/Mozilla-l10n/ - todays build failed apparently, but there still should be an update to yesterdays build, shouldn't it?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This will happen whenever we have l10n nightlies fail, until AUS copes with it better. This happened again this morning. I've re-kicked a set of nightlies, and l10n builds should recover again tomorrow.

I don't think there's any reason to keep this bug open.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.