Closed Bug 58865 Opened 21 years ago Closed 21 years ago

Ctrl-Q exit shortcut should ask for confirmation

Categories

(SeaMonkey :: UI Design, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 39057

People

(Reporter: st.n, Assigned: don)

Details

In NS4 and earlier on UNIX, there is an X resource setting called `confirmExit',
which, when set to true, pops up a dialog asking for confirmation when the user
presses Alt-Q (now Ctrl-Q in Mozilla). This was very useful, since it often
happens that I accidentially hit Ctrl-Q instead of Ctrl-W to close a window.
It is very annoying when you have lots of windows open and they all disappear
at once.

IMHO this should even be the default, but making it a pref would also help. And
meybe the confirmation could be omitted if there is only one window open, since
there wouldn't be any difference between Ctrl-W and Ctrl-Q in that case.
Component: Keyboard Navigation → XP Apps
Keywords: 4xp, pp
Confirmed. Marking this as new so someone will look at it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
afaik, at least on win32 and Mac, when there's more than one communicator
window, i'll get a warning when i attempt to quit by either the shortcut or the
menu item. i don't seem to get that warning, however, in 4.7x on linux [but
perhaps i need to have a hidden pref set?]

in any case, i do agree with you: if there's more than one mozilla [or netscape
6] window, we should give a warning to the user.
Keywords: pp
We should definitely make sure that there is a way to turn this warning off.

A pref sounds like the easiest way, since GTK does not really do X resources...
dup

*** This bug has been marked as a duplicate of 39057 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
whoops, forgot about that earlier bug.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.